Bug 138137 - EDITING Merged cells don’t lose detective circles when correct value is entered
Summary: EDITING Merged cells don’t lose detective circles when correct value is entered
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Tibor Nagy (NISZ)
URL:
Whiteboard: target:7.2.0 target:7.1.0.0.beta2
Keywords:
Depends on:
Blocks: Cell-Validity
  Show dependency treegraph
 
Reported: 2020-11-11 14:48 UTC by NISZ LibreOffice Team
Modified: 2020-12-30 10:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Calc (8.59 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-11-11 14:48 UTC, NISZ LibreOffice Team
Details
Screenshot of the file before changing the values in Calc (22.01 KB, image/png)
2020-11-11 14:49 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem in Calc (22.71 KB, image/png)
2020-11-11 14:49 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-11-11 14:48:48 UTC
Created attachment 167202 [details]
Example file from Calc

Attached document contains some cells with data validation rule of Whole numbers greater than 5.
The detective circled the values that are not greater than 5, but entering correct values to merged cells does not remove the circles, unlike with normal cells.

Steps to reproduce:
    1. Open attached file
    2. Enter 6 in the circled cells

Actual results:
The merged cells don’t lose their red circle. The non-merged ones disappears (since bug #125462 was fixed)

Expected results:
Merged cells should lose their red circle once a correct value is entered.

LibreOffice details:
Version: 7.1.0.0.alpha1+ (x64)
Build ID: 00e5c63c35307faacf76a5e2ca7953c4208244ed
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-11-11 14:49:33 UTC
Created attachment 167203 [details]
Screenshot of the file before changing the values in Calc
Comment 2 NISZ LibreOffice Team 2020-11-11 14:49:53 UTC
Created attachment 167204 [details]
Screenshot of the problem in Calc
Comment 3 Commit Notification 2020-11-24 09:59:47 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6975e4387640a1473ca158f503637be61ac9dedb

tdf#138137 sc: remove red circle in merged cell

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2020-11-24 15:40:20 UTC
Tibor Nagy committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/fbf92ea796a398f0fceb1613aad0a3d682dd2403

tdf#138137 sc: remove red circle in merged cell

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 NISZ LibreOffice Team 2020-12-30 10:39:55 UTC
Verified in:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 368c56144aab5794c39d5bc2082d9b3d6d7cebdb
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded

Thanks for fixing!