Bug 138163 - font size changing during data entry in Calc
Summary: font size changing during data entry in Calc
Status: RESOLVED DUPLICATE of bug 83568
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.6.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-12 14:01 UTC by CJ_NZ
Modified: 2021-05-17 10:02 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description CJ_NZ 2020-11-12 14:01:25 UTC
Description:
During data entry in Calc, the font size appears to randomly change [presumably to the default] and ignores any previous setting for the file/sheet/range selected and also the template settings upon which the file is based.  

Steps to Reproduce:
1. Create a Calc file. Select All, set the font size to say 8. Save file. 
2. Work away until you notice the font size is inexplicably and randomly using 10 
3. Select All, set the font size to 8 again. Save file. Goto step 2 :)

Actual Results:
Regardless of the number times I 'Select All' and set font size to 8, the problem recurs and has been doing so for many releases. It seems as if the program is randomly reverting to some default rather than recognizing the specific user settings and/or template settings.   

Expected Results:
Problem persists across releases on both Mac OSX and Linux Mint (latest updates)


Reproducible: Sometimes


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
It would be preferable for application to comply with user settings.
Comment 1 Timur 2020-11-13 13:11:20 UTC
Steps must be always reproducible. Please try to find out. 
No point in keeping Unconfirmed. I change to NeedInfo. 
Hopefully will reporter write steps or someone else will see this in 6 months (which is lifetime for Needinfo).
Comment 2 QA Administrators 2021-05-13 03:58:53 UTC Comment hidden (obsolete)
Comment 3 CJ_NZ 2021-05-15 15:30:58 UTC
This bug persists in LibreOffice (7.0.5.2) Calc under MacOS (10.15.7) and possibly other OS (although I have not used it under other OS as yet). However, I think I know what may be causing it, namely a conflict between the following "defaults"

1) Install defaults (set by package builder) - Lets call these "factory defaults"
2) LibreOffice preferences - Lets call these "user defaults"
3) Style menu - Let's call these "file defaults"   

Specifically, if no file defaults are explicitly set but instead the user selects the whole sheet and individually sets attributes like font size, Bold etc, Calc randomly ignores those actions and uses the "user defaults" instead...
Comment 4 Timur 2021-05-17 10:02:23 UTC
Looks duplicate.

*** This bug has been marked as a duplicate of bug 83568 ***