Bug 138290 - Crash swlo!SwAnchoredObject::ConsiderObjWrapInfluenceOnObjPos+0x21 after changing anchor to character
Summary: Crash swlo!SwAnchoredObject::ConsiderObjWrapInfluenceOnObjPos+0x21 after chan...
Status: RESOLVED DUPLICATE of bug 138056
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-11-17 18:27 UTC by Telesto
Modified: 2020-12-04 08:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-11-17 18:27:33 UTC
Description:
Crash swlo!SwAnchoredObject::ConsiderObjWrapInfluenceOnObjPos+0x21 after changing anchor to character

Steps to Reproduce:
1. Open attachment 167355 [details] (bug 138282 )
2. Right click Dotted textbox at bottom page 1
3. Change anchor to 'to character'

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.0.alpha1+ (x64)
Build ID: 312a33b7636334f6ce3b6d1702bc5d3e45215601
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-11-17 21:48:21 UTC
Not in 
6.2
Comment 2 Xisco Faulí 2020-11-18 16:01:44 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c9eb53f200225f2ee6ca695e1326843a487aee51

author	Daniel Arato (NISZ) <arato.daniel@nisz.hu>	2020-10-14 15:46:23 +0200
committer	László Németh <nemeth@numbertext.org>	2020-10-27 13:27:55 +0100
commit	c9eb53f200225f2ee6ca695e1326843a487aee51 (patch)
tree	a9bcf31a6e32b81a4fd42cb7a65936a075928213
parent	ebea072fa7d7081ba9d1e549f5aa629c749d8c0e (diff)
tdf#135198 sw editing: text box fell out of its shape

Bisected with: bibisect-linux64-7.1

Adding Cc: to Daniel Arato
Comment 3 Dániel Arató (NISZ) 2020-12-04 08:41:04 UTC

*** This bug has been marked as a duplicate of bug 138056 ***