Bug 138302 - Restart of numbering is not saved when saving to DOC
Summary: Restart of numbering is not saved when saving to DOC
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.5.2 release
Hardware: All All
: high normal
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:7.2.0 target:7.1.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-11-18 03:33 UTC by Ross Woods
Modified: 2021-08-02 14:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (13.75 KB, application/vnd.oasis.opendocument.text)
2020-11-20 08:05 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ross Woods 2020-11-18 03:33:07 UTC
Writer, Format, Lists, Restart numbering

The restart of numbering is not saved. When the document is opened again, the numbering reverts to one continuous series throughout the documents.
Comment 1 Telesto 2020-11-18 22:40:38 UTC Comment hidden (obsolete)
Comment 2 Telesto 2020-11-20 08:05:44 UTC
Created attachment 167412 [details]
Example file

Example file received by e-mail
Comment 3 Telesto 2020-11-20 08:06:14 UTC
Confirm with
Version: 7.1.0.0.alpha1+ (x64)
Build ID: 312a33b7636334f6ce3b6d1702bc5d3e45215601
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 4 Telesto 2020-11-20 08:12:06 UTC
Still fine with
Version: 6.0.6.0.0+
Build ID: c30963b8b4bbbe42a24b97aafa161eff9d7ccdd4
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL


Looks like a export issue. Opening they 6.0 with 7.1 is fine. Let's raise priority a bit, as still care about DOC. 
FWIW: Priority is open for debate, so might overstepping my boundaries; so might be downgraded again :P. We will now soon enough
Comment 5 Justin L 2020-11-25 18:07:47 UTC
bibisect-linux-64-7.0 bisect commit 24a4135513e09207bbd1b249a19d748299df52b8

author	Vasily Melenchuk on 2020-04-22 18:03:02 +0200
commit	cf13fe3e6f6a40f6db064d65d4514d13a23a31f0
tdf#108496: DOCX: redesign of override in lists

https://cgit.freedesktop.org/libreoffice/core/commit/?id=cf13fe3e6f6a40f6db064d65d4514d13a23a31f0

This was backported to 6.4.5.

cc'd Vasily Melenchuk.
Comment 6 Commit Notification 2021-05-31 06:59:14 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f49e5902a3737c02fabf5bec23243ccb126426c4

tdf#138302 partial revert tdf#108496: DOCX: redesign of override in lists

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2021-05-31 08:52:09 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/5107bc515fba130bf4a488324f97971789a92f37

tdf#138302 partial revert tdf#108496: DOCX: redesign of override in lists

It will be available in 7.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-06-01 07:44:40 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-4":

https://git.libreoffice.org/core/commit/601260714561a22a1250ceeb7b746d80a7f7f7ff

tdf#138302 partial revert tdf#108496: DOCX: redesign of override in lists

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Thorsten Behrens (allotropia) 2021-06-07 01:10:55 UTC
Seen fixed in master and 7.1
Comment 10 Rober James 2021-08-02 04:40:59 UTC Comment hidden (spam)