Bug 138308 - Inconsistency of password length for *.docx and *.odt documents
Summary: Inconsistency of password length for *.docx and *.odt documents
Status: RESOLVED DUPLICATE of bug 97086
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.5.2 release
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-18 11:10 UTC by Filipp Bezold
Modified: 2020-11-18 11:23 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filipp Bezold 2020-11-18 11:10:59 UTC
Description:
Dear LibreOffice team,
I'm working for my job with LibreOffice in a mainly Microsoft Office enviroment, and did not experience any significant downturns yet.
For a collaboration I received a *.docx document and was able to open it with the provided 16 character password. My attemp to save this document with the same password (*.docx or *.odt) failed, because libreoffice writer only alows 15 characters. I wanted to report this because I believe fixing this issue should be fairly easy. Keep up your great work.

Steps to Reproduce:
1.set a pw of 16 characters with MS Word
2.open the document with Libreoffice Writer using the password
3.Try to save the document with the same password

Actual Results:
complains that only 15 characters are allowed for a pw

Expected Results:
a regular save of the document


Reproducible: Always


User Profile Reset: No



Additional Info:
accept 16 characters as a pw
Comment 1 Mike Kaganski 2020-11-18 11:23:21 UTC

*** This bug has been marked as a duplicate of bug 97086 ***