Bug 138314 - Blank tab names in dialog frames, macOS 11 Big Sur
Summary: Blank tab names in dialog frames, macOS 11 Big Sur
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: All Mac OS X (All)
: high normal
Assignee: Thorsten Wagner
URL:
Whiteboard: target:7.2.0 target:7.1.1 target:7.1.2
Keywords:
: 138610 139221 139465 139554 139957 140025 140999 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-11-18 18:59 UTC by photeinos.santas
Modified: 2021-03-14 11:32 UTC (History)
15 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshots for blank tag names (679.74 KB, application/zip)
2020-11-18 18:59 UTC, photeinos.santas
Details
Further info provided on bug #138314 (893.27 KB, image/png)
2020-11-19 08:59 UTC, photeinos.santas
Details
7.1.1.1 unfixed (1.21 MB, image/png)
2021-02-14 22:59 UTC, steve
Details
LibreOffice 7.1.1.2 (2.40 MB, image/png)
2021-02-28 20:50 UTC, José Luís Andrade
Details

Note You need to log in before you can comment on or make changes to this bug.
Description photeinos.santas 2020-11-18 18:59:39 UTC
Created attachment 167389 [details]
Screenshots for blank tag names

When clicking on a tab in an open Writer dialog, the tag label turns blank. See attached zipped screenshots.
Comment 1 V Stuart Foote 2020-11-18 23:36:39 UTC
All on macOS.

Please post details from Help -> About LibreOffice

And your macOS about this Apple details (need os build, screen resolution, and graphics GPU).
Comment 2 photeinos.santas 2020-11-19 08:59:41 UTC
Created attachment 167394 [details]
Further info provided on bug #138314

Further info provided on bug #138314, namely, LibreOffice Version and Build, MacOS Version and build, screen resolution and graphics GPU.
Comment 3 V Stuart Foote 2020-11-19 10:22:51 UTC
OK, so rendering issues on macOS 11.0.1 Big Sur on Iris Retina display. More Xcode fun...
Comment 4 Heiko Tietze 2020-11-19 14:12:33 UTC
Confirming, the active tab is white.
Comment 5 mrei 2020-12-05 08:43:56 UTC
I don't have Big Sur available to test this on, or a retina display
But I can at least confirm this is not occurring for me

11.6-inch (1366 x 768)
ntel HD Graphics 3000 384 MB graphics

Version: 7.1.0.0.beta1+
Build ID: 73d98236ea83296018e6da30d0d7ec0219313776
CPU threads: 4; OS: Mac OS X 10.13.6; UI render: default; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 6 Tor Lillqvist 2020-12-05 12:14:26 UTC
If you want to make it easy for developers and QA people to look at your screenshot(s), just attach them as such, not in a zip archive. I will bother opening the archive now, sure, but in the future. Thanks.
Comment 7 Tor Lillqvist 2020-12-05 12:18:36 UTC
Can reproduce, yes. Presumably caused by relatively recent (well, this year) changes to make LO's UI look more native. Ping Thorsten Wagner, any idea?
Comment 8 Tor Lillqvist 2020-12-05 12:21:10 UTC
See also bug #125532.
Comment 9 Roman Kuznetsov 2020-12-05 13:25:11 UTC
*** Bug 138610 has been marked as a duplicate of this bug. ***
Comment 10 Roman Kuznetsov 2020-12-05 13:25:27 UTC
It isn't a problem with Retina, I have the same problem on fullHD screen with macOS 11 Big Sur
Comment 11 Thorsten Wagner 2020-12-05 14:11:27 UTC
(In reply to Tor Lillqvist from comment #7)
> Can reproduce, yes. Presumably caused by relatively recent (well, this year)
> changes to make LO's UI look more native. Ping Thorsten Wagner, any idea?

Not sure whether this issue is really related to these changes - it seems to be a Big-Sur-only issue. I am currently investigating this issue, but depending on time I have to delay futher investigations until the days after christmas.
Comment 12 Roman Kuznetsov 2021-01-16 12:57:02 UTC
*** Bug 139554 has been marked as a duplicate of this bug. ***
Comment 13 Roman Kuznetsov 2021-01-16 12:57:48 UTC
*** Bug 139465 has been marked as a duplicate of this bug. ***
Comment 14 Roman Kuznetsov 2021-01-16 12:59:03 UTC
high importance since we have 10 CCed users
Comment 15 Thorsten Wagner 2021-01-17 19:44:44 UTC
Patch submitted to Gerrit:

https://gerrit.libreoffice.org/c/core/+/109479
Comment 16 Thorsten Wagner 2021-01-17 19:48:09 UTC
There is an request from OpenJDK developers to Apple concerning the same issue. The request was not answered by Apple until now.
Comment 17 Commit Notification 2021-01-17 20:39:11 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/058ad4b900b5e0ee902f3e89ed121c2b5f8c58f1

tdf#138314 Change selected tab text color on macOS Big Sur

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2021-01-18 07:07:21 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/1cf7ce5a57e50a734258b83a3919a59aa535241f

tdf#138314 Change selected tab text color on macOS Big Sur

It will be available in 7.1.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 steve 2021-01-18 10:32:53 UTC
Changing to fixed, as there now is a patch for this problem. @Thorsten feel free to switch again if that is a false assumption.
Comment 20 Xisco Faulí 2021-01-28 09:49:07 UTC
*** Bug 139957 has been marked as a duplicate of this bug. ***
Comment 21 Roman Kuznetsov 2021-01-31 12:47:35 UTC
*** Bug 140025 has been marked as a duplicate of this bug. ***
Comment 22 Roman Kuznetsov 2021-01-31 12:48:47 UTC
(In reply to Commit Notification from comment #18)
> Thorsten Wagner committed a patch related to this issue.
> It has been pushed to "libreoffice-7-1":
> 
> https://git.libreoffice.org/core/commit/
> 1cf7ce5a57e50a734258b83a3919a59aa535241f
> 
> tdf#138314 Change selected tab text color on macOS Big Sur
> 
> It will be available in 7.1.1.
> 

Thorsten, what about backport it into 7.0 versions?
Comment 23 Tor Lillqvist 2021-01-31 13:26:40 UTC
Roman, I don't think it is up to Thorsten to take care of back-ports. He is a volunteer doing this on his own time and we should not expect him to work on anything except the master branch.
Comment 24 Roman Kuznetsov 2021-01-31 14:16:51 UTC
(In reply to Tor Lillqvist from comment #23)
> Roman, I don't think it is up to Thorsten to take care of back-ports. He is
> a volunteer doing this on his own time and we should not expect him to work
> on anything except the master branch.

Ok, Tor may be you can backport it to 7.0 if it's possibly? Users just write bug reports about this problem and they use LO 7.0
Comment 25 Tor Lillqvist 2021-01-31 14:25:28 UTC
I could, but so could other people.
Comment 26 steve 2021-02-14 22:59:07 UTC
Created attachment 169743 [details]
7.1.1.1 unfixed
Comment 27 steve 2021-02-14 23:05:29 UTC
Should this be fixed as per whiteboard in 7.1.1.1?
Comment 28 Roman Kuznetsov 2021-02-25 12:19:12 UTC
*** Bug 139221 has been marked as a duplicate of this bug. ***
Comment 29 José Luís Andrade 2021-02-28 20:50:36 UTC
Created attachment 170133 [details]
LibreOffice 7.1.1.2
Comment 30 José Luís Andrade 2021-02-28 20:51:32 UTC
Not fixed to LibreOffice 7.1.1.2
Comment 31 steve 2021-03-04 18:55:32 UTC
Re-opening this, as I can confirm it is not fixed in 7.1.1.2.
Comment 32 Roman Kuznetsov 2021-03-04 19:56:06 UTC
(In reply to steve from comment #31)
> Re-opening this, as I can confirm it is not fixed in 7.1.1.2.

nor in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 75175049972239cfceab15c7b756fe0a2c4059be
CPU threads: 4; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: ru-RU (ru_RU.UTF-8); UI: en-US
Calc: threaded Jumbo

build from 04 March 2021
Comment 33 Thorsten Wagner 2021-03-04 20:24:24 UTC
Cannot reproduce with my Big Sur build, but probably the reason is compartibiliy mode of earlier SDK releases (which are used to build LO shipment release).

It would be very nice to get the following tested. Start LO using

export SYSTEM_VERSION_COMPAT=0 && /Applications/LibreOffice.app/Contents/MacOS/soffice

Issue should disappear if my assumption is correct. If someone is able to confirm this I will prepare a second patch during the next days to archive compatibility with the SDK releases used within the LO build chain.
Comment 34 bones 2021-03-05 06:27:14 UTC
I can confirm, that using "export SYSTEM_VERSION_COMPAT=0 && /Applications/LibreOffice.app/Contents/MacOS/soffice" to start LE solved the problem with the blank tab names.

LO: 
Version: 7.1.1.2 / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 16; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded
Comment 35 photeinos.santas 2021-03-05 10:00:27 UTC
I confirm too that the problem with blank tab names has been fixed, using the 
"export SYSTEM_VERSION_COMPAT=0 &&/Applications/LibreOffice.app/Contents/MacOS/soffice" command to start LO from the Terminal.

This is a temporary fix, however, lasting for the LO instance running as stated above. Once you quit this instance and run LO by double clicking on it from the Applications folder, the issue returns.

LO:
Version: 7.1.1.2 / LibreOffice Community
Build ID: fe0b08f4af1bacafe4c7ecc87ce55bb426164676
CPU threads: 8; OS: Mac OS X 11.2.2; UI render: default; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Hardware:
  Model Name:	MacBook Pro
  Model Identifier:	MacBookPro11,3
  Processor Name:	Quad-Core Intel Core i7
  Processor Speed:	2.5 GHz
  Number of Processors:	1
  Total Number of Cores:	4
  L2 Cache (per Core):	256 KB
  L3 Cache:	6 MB
  Hyper-Threading Technology:	Enabled
  Memory:	16 GB
  System Firmware Version:	430.0.0.0.0
  SMC Version (system):	2.19f12
  Serial Number (system):	C02NJ6X4G3QD
  Hardware UUID:	580F7C30-5291-502F-B779-F522F6F2323B
  Provisioning UDID:	580F7C30-5291-502F-B779-F522F6F2323B
Comment 36 Thorsten Wagner 2021-03-06 00:44:22 UTC
Patch submitted to Gerrit:

https://gerrit.libreoffice.org/c/core/+/112036
Comment 37 Commit Notification 2021-03-06 06:18:30 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d8fc89cdfd0043838c4bc2d3b5a50bf5abfc6738

tdf#138314 Change selected tab text color on macOS Big Sur

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 38 steve 2021-03-07 09:33:48 UTC
Retested todays master https://dev-builds.libreoffice.org/daily/master/

Verified, Fixed

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 3d008f3bcd19a74cff0781cbd9a3d173892553cf
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: de-DE (de_DE.UTF-8); UI: en-US
Calc: threaded

Thanks so much Thorsten for doing the heavy-lifting on all those macOS problems. Hope you get the well deserved appreciation.
Comment 39 Thorsten Wagner 2021-03-07 11:48:24 UTC
(In reply to steve from comment #38)
> Retested todays master https://dev-builds.libreoffice.org/daily/master/
> 
> Verified, Fixed
> 
> Version: 7.2.0.0.alpha0+ / LibreOffice Community
> Build ID: 3d008f3bcd19a74cff0781cbd9a3d173892553cf
> CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
> Locale: de-DE (de_DE.UTF-8); UI: en-US
> Calc: threaded
> 
> Thanks so much Thorsten for doing the heavy-lifting on all those macOS
> problems. Hope you get the well deserved appreciation.

Thanks for testing. Comments like yours are appreciation enough. Backport to LO 7.1 submitted to Gerrit:

https://gerrit.libreoffice.org/c/core/+/112105
Comment 40 Commit Notification 2021-03-09 07:05:01 UTC
Thorsten Wagner committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/19badc601594a19b56cff14076435f96e51ce845

tdf#138314 Change selected tab text color on macOS Big Sur

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 41 Roman Kuznetsov 2021-03-14 11:32:19 UTC
*** Bug 140999 has been marked as a duplicate of this bug. ***