Bug 138459 - Particular Draw OLE object causes Skia related CRASH
Summary: Particular Draw OLE object causes Skia related CRASH
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) rc
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
Depends on:
Blocks: Skia
  Show dependency treegraph
Reported: 2020-11-24 12:56 UTC by Rainer Bielefeld Retired
Modified: 2020-11-30 16:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

Source for OLE object (31.65 KB, application/vnd.oasis.opendocument.graphics)
2020-11-24 12:56 UTC, Rainer Bielefeld Retired
screenshot (149.67 KB, image/png)
2020-11-25 20:06 UTC, Julien Nabet

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2020-11-24 12:56:20 UTC
Created attachment 167533 [details]
Source for OLE object

Steps how to reproduce with Version: (x64)
CPU-Threads: 4; BS: Windows 6.1 Service Pack 1 Build 7601; UI-Render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: Threaded
Elementary theme

1. Open attachment 
2. ˋClick Drawing object "Envelope" → Rightclick  → Copyˊ
3. Menu ˋFile → New → Text Documentˊ    
   » New document opens
4. ˋRightclick into Text Document → Pasteˊ
    » Expected: "Envelope" inserted, everything is fine
        "Idle" Mouse Pointer, heavy CPU load (persisting), 
        After Object has become visible in Writer it will show ugly horizontal
        hatching instead of gadients (what might be a separate bug)
        Double click on element for me after few seconds will cause crash 
          on this PC (others not yet tested)

Additional information
a) no problem in CALC
b) worked fine for me with I dropped few days ago
c) Crash report ID 697b3a54-fe6b-4580-96b6-28c39ec3ac01 (?)
Comment 1 Rainer Bielefeld Retired 2020-11-24 13:41:01 UTC
Works better with 
Version: (x64)
Build ID: 828a45a14a0b954e0e539f5a9a10ca31c81d8f53
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL
Independent User Profile

Still very heavy CPU load for any action in Writer document from step 4
But hatching has gone, and no more CRASH.
Comment 2 Rainer Bielefeld Retired 2020-11-24 13:49:28 UTC
d) I tried with newly created User Profile: 
   Hatching and high processor load remain, but no more crashes.
   Crash has reappeared when I switched back to my default UserProfile
Comment 3 Julien Nabet 2020-11-25 20:06:40 UTC Comment hidden (obsolete)
Comment 4 Julien Nabet 2020-11-25 20:07:16 UTC
Comment on attachment 167575 [details]

On pc Debian x86-64 with master sources updated today gen rendering, I don't reproduce this but perhaps Windows only
Comment 5 Rainer Bielefeld Retired 2020-11-27 08:22:14 UTC
makes this Version unusable for me. Dropped!
Comment 6 Julien Nabet 2020-11-27 17:13:16 UTC
Perhaps you can try these:
I mean specifically OpenGL and Skia part.
I think 6.4 uses more OpenGL and 7.0 more Skia.

BTW, there's a transition from OpenGL towards Skia because too much problems with OpenGL and almost nobody to fix these. Hope it won't be the case with Skia but I'm not so sure since there's only 1 person who really works on it. So if he leaves for any reason, I don't know who may tackle the future Skia bugs.

Hope you're fine! :-)
Comment 7 Rainer Bielefeld Retired 2020-11-28 08:11:08 UTC
Problems indeed are Sika related. 
e) Menu ˋTools → Options → View → uncheck all use Sika optionsˊ heals the problem.
Comment 8 Julien Nabet 2020-11-28 08:21:16 UTC
Rainer: just to be sure because I'm almost you've already done it, could you confirm your graphic driver is up-to-date?

Luboš: thought you might be interested in this one since it concerns Skia.
Comment 9 Julien Nabet 2020-11-28 08:33:03 UTC
Rainer: forgot to tell, would it be possible you retrieve <user profile>/cache/skia.log, and attach it to the bug report? Perhaps we'll only blacklist the driver. Indeed, I just noticed that you indicated Windows 6.1 (so Win7).

Argh, it just remembered me:
disable Vulkan for Windows 7 (tdf#138219)
The bugreport says the latest Intel drivers for Windows 7 are
problematic, and since Windows 7 is EOL anyway, simply don't bother.

So I suppose DUPLICATE of tdf#138219, WONTFIX ?

Sorry for the noise Luboš.
Comment 10 Luboš Luňák 2020-11-28 14:42:13 UTC
The report says "UI-Render: Skia/Raster", so it should not be driver-related. Still, the reported crashreport has no useful information, so this needs a way to reproduce the problem.
Comment 11 Rainer Bielefeld Retired 2020-11-29 08:20:06 UTC
> graphic driver is up-to-date?
I'm afraid on my vintage IWN7 PC nothing can be really up to date :-/ 

Problem only is reproducible on
64 bit AMD Phenom II X4 955 Processor 3.2 GHz, 4GB RAM, 
Graphic Card: NVIDIA GeForce GT 430, Monitor HANNS-G HL225DBB 1920 x 1080 
WIN7 64 bit

No Problem on my WIN10 - System
Comment 12 Julien Nabet 2020-11-29 11:08:29 UTC
Rainer: at least your pc may help to detect pbs on "legacy" pcs. Of course, I suppose you already know that Windows 7 is no more supported by Microsoft except for some security updates (see https://en.wikipedia.org/wiki/Windows_7)

In addition to WONTFIX or DUPLICATE, we may also choose FIXED (with https://cgit.freedesktop.org/libreoffice/core/commit/?id=a72b0ae16684feb438558686253d9b4701313017) even if it's not a real fix but a by default blacklist which allows to make LO work out-of-the-box.

Xisco: I let you read the comments, I don't know how we should keep on here, thought you might have some opinion.
Comment 13 Luboš Luňák 2020-11-30 14:57:50 UTC
If you can reproduce this only with one user profile, then most likely it's specific to some option enabled in that profile. So you can try to find out which option is the one that's different and is causing this, otherwise I don't see a way to find out what's wrong here.
Comment 14 Rainer Bielefeld Retired 2020-11-30 16:18:47 UTC
Seems to be some bad interaction between my PC - OS - User Profile  - LibO Version. More or less RESOLVED WFM with 7.1

So NOTROURBUG for now.