Bug 138484 - OPTIONS DIALOG: Settings for printing comments have no effects
Summary: OPTIONS DIALOG: Settings for printing comments have no effects
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords: bibisected
: 140068 (view as bug list)
Depends on:
Blocks: Writer-Comments Options-Dialog-Writer
  Show dependency treegraph
 
Reported: 2020-11-25 12:54 UTC by Daniele
Modified: 2021-03-14 10:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniele 2020-11-25 12:54:13 UTC
Description:
Libreoffice/Preferences/LibreOffice Writer/Print Comments settings options (A) do not get reflected in File/printer settings (B) and viceversa.
So I for ex. chose to have comments printed in margins in A and no comments were printed. Checked in B and none were selected. So I selected comments in margins in B. and comments were printed. Now if I change somenthing in A it will not be reflected in B and viceversa.

Steps to Reproduce:
1.Create a document with comments.
2.Choose in LO preferences to have comments printed in margins (apply, save)
3. No comments are printed
4. Go to File/printer settings/options and do the same choice here
5. Comments are printed now.

Actual Results:
No comments printed using LO prefernces and no changes in the Printer settings options.

Expected Results:
Printer settings should reflect LO settings. 


Reproducible: Always


User Profile Reset: No



Additional Info:
Samsung ML-1680 Series
Mac OS 10.13.6
Comment 1 Dieter 2020-12-22 15:33:23 UTC
I confirm it with

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 315c7570c4a72f4c834086082825533b1e50d1bf
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

Steps to reproduce
1. open a document with comments
2. Tools => Options => LibreOffice Writer => Print
3. Choose a setting for printing comments

Actual result
a) Print Preview doesn't show comments (bug 91688)
b) Preview in print dialog doesn't show comments
c) Comments are not printed
Comment 2 Timur 2021-02-25 10:48:19 UTC
This bug should be easily seen and I reproduced but not consistently. 
Should be a regression, I tried to bibisect but couldn't repro then. 
So I add Buovjaga, maybe he will have more luck here.
Comment 3 Buovjaga 2021-02-25 11:11:18 UTC
Bibisected with linux-64-7.0 to range
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=807e075a6184f7afc01a127abe77391238ab4163...25cca30ef5f27b0a20ea7da79d0ddea66dc98d93
out of which this seems relevant:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=d23c52cbf7e48130fec1e48bf726c563035a3497
tdf#47583 sw: Don't mix doc print settings into option dialog

Adding Cc: to Michael Weghorn
Comment 4 Michael Weghorn 2021-02-25 12:23:36 UTC
(In reply to Buovjaga from comment #3)
> Bibisected with linux-64-7.0 to range
> https://cgit.freedesktop.org/libreoffice/core/log/
> ?qt=range&q=807e075a6184f7afc01a127abe77391238ab4163...
> 25cca30ef5f27b0a20ea7da79d0ddea66dc98d93
> out of which this seems relevant:
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=d23c52cbf7e48130fec1e48bf726c563035a3497
> tdf#47583 sw: Don't mix doc print settings into option dialog
> 
> Adding Cc: to Michael Weghorn

Indeed, that's the commit that changes the behavior. The change was intended; quoting from my own commit message:

> tdf#47583 sw: Don't mix doc print settings into option dialog
> 
> Show and manage the default Writer print options in the "Tools" ->
> "Options" -> "LibreOfficeDev Writer" -> "Print" dialog and don't
> mix in the document-specific values of the currently opened
> document, as this is rather confusing as described in tdf#47583.
> 
> There is a separate dialog to manage the settings for the currently
> opened document available via "File" -> "Printer Settings" -> "Options".
> 
> At a quick glance, this also matches the behaviour for Calc, which
> doesn't mix in the current doc's settings either.
> 
> This handles the case for the Writer-specific print options.
> For a more general approach on whether and how document-specific
> options should be handled in the "Tools" -> "Options" dialog at all,
> there are already tdf#43786 ("Intransparent Use of Options")  and
> tdf#105751 ("Separate document saved options from global options in
> Options dialog").
> 
> Side note: The previous implementation also wasn't synchronizing the
> settings both ways. Changes made in the "File" -> "Printer Settings" ->
> "Options" dialog did show up in the "Tools" -> "Options" ->
> "LibreOfficeDev Writer" -> "Print" dialog at once, but not the other
> way around.

The setting in "Tools" -> "Options" defines the default value to use for *new* documents, while the one in "File" -> "Printer Settings" handles that of the current document, i.e. changing the one in "Tools" -> "Options" will only take effect when creating a new document.

See tdf#47583 for more background which describes how the previous behavior was even more confusing.

Inserting a corresponding heading/tag as suggested in the proposal from tdf#47583 comment 0 would probably help to make this clearer:

> Proposal in order to make the behaviour more transparent:
> Insert a heading to the option category 'LibreOffice Writer > Print': "Initial Print Options of new Documents". And of course print options of current documents should not longer displayed in the general options dialog.

IMHO, if changed, that should be handled consistently with other places as well, s. my tdf#47583 comment 14:

> I'm looking into the second aspect mentioned here (not displaying document-specific settings in "Tools" -> "Options"; Calc also doesn't do this).
> I suggest to then handle the "remainder" (i.e. proper labels/headings) in bug 118262, where this is also already mentioned.

tdf#118262 mentions more areas where the current handling of general/file-specific options is not ideal.


Given that, I'd suggest that this is not a regression but a "Works For Me" (but I agree that it may be confusing, s. above comments with further details and existing ideas/tickets to improve this further).
Comment 5 Michael Weghorn 2021-02-25 12:26:06 UTC
(In reply to Michael Weghorn from comment #4)
> Given that, I'd suggest that this is not a regression but a "Works For Me"

... or rather "Not a bug" or a duplicate of tdf#118262?
Comment 6 Buovjaga 2021-02-25 12:55:47 UTC
Ok, sorry for the noise.

*** This bug has been marked as a duplicate of bug 118262 ***
Comment 7 Timur 2021-02-25 14:05:38 UTC
Thanks for the explanation. I didn't find it when searching for duplicates. 

I'd rather convert this bug to Documentation, because other bug is action bug, has some expected steps. 
Current help seems slim on this.
Comment 8 Olivier Hallot 2021-03-04 09:17:27 UTC
*** Bug 140068 has been marked as a duplicate of this bug. ***
Comment 9 Olivier Hallot 2021-03-04 09:27:06 UTC
The Help page for Print Options 

https://help.libreoffice.org/7.1/en-GB/text/shared/optionen/01040400.html?System=WIN&DbPAR=WRITER&HID=modules/swriter/ui/printoptionspage/PrintOptionsPage#bm_id3153750

has a note

"The print settings defined on this tab page apply to all subsequent print jobs, until you change the settings again. If you want to change the settings for the current print job only, use the File - Print dialog."

I'll correct "to subsequent new documents".

If not enough, please shout here.
Comment 10 Commit Notification 2021-03-04 11:17:45 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/e661fb9ccdc7d6bf364aa4a4e3b5e9f74acf8278

tdf#138484 Clarify Writer Print Options are for new documents