Bug 138523 - Drawing object and Fontwork object do not share z-index context for layer 'arrange' in Calc
Summary: Drawing object and Fontwork object do not share z-index context for layer 'ar...
Status: RESOLVED DUPLICATE of bug 134355
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-27 08:08 UTC by Pichate
Modified: 2021-02-08 18:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pichate 2020-11-27 08:08:35 UTC
Description:
Drawing Object and fontwork object can't arrange (bring forward or bring backward between those object ) for Example I create rectangular and then I create fontwork object , I can't bring fontwork over rectangular 

Steps to Reproduce:
1.Create Rectangular object
2.Create Fontwork object
3.arrang Fontwork object to front of Rectangular object

Actual Results:
Fontwork object still behind the drawing object

Expected Results:
Fontwork object should be overlay the drawing object


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 V Stuart Foote 2020-11-27 15:06:03 UTC
Confirmed.

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 9c355a82881d8e13d6bc732e13b28d62962bf245
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

The Fontwork and Draw objects do not seem to share the same z-index context on the Calc sheet. 

Two draw objects can be z-order arranged. Two fontwork objects can be z-order arranged. But the object types can not be mixed in context.

Does not occur on Writer canvas where they can be mixed. And of course these Draw objects behave in Draw & Impress.
Comment 2 Regina Henschel 2021-02-08 18:42:58 UTC
The error is, that custom shapes are erroneously put on layer "controls", which is a special layer, only to be used for form controls.

*** This bug has been marked as a duplicate of bug 134355 ***