Bug 138526 - Image missing for new Formats Only option
Summary: Image missing for new Formats Only option
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Icon-Theme-Breeze Icon-Theme-Colibre Icon-Theme-KarasaJaga Icon-Theme-Elementary Icon-Request Icon-Theme-Sifr Icon-Theme-Sukapura
  Show dependency treegraph
 
Reported: 2020-11-27 13:02 UTC by Heiko Tietze
Modified: 2021-08-03 22:54 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Missing icon in LO 7.2.0 RC2 (48.54 KB, image/png)
2021-08-03 13:04 UTC, stragu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2020-11-27 13:02:53 UTC
With bug 134802 a new preset was introduced that inserts "Formats Only". Please add the image as sc/res/paste_formats_only.png
Comment 1 Rizal Muttaqin 2020-11-28 06:53:27 UTC
(In reply to Heiko Tietze from comment #0)
> With bug 134802 a new preset was introduced that inserts "Formats Only".
> Please add the image as sc/res/paste_formats_only.png

Please tell me what's is Formats Only here? Is it supposed to be number formatting  (date, currency, etc) or more like style formatting (color, bold, etc)?
Comment 2 Heiko Tietze 2020-11-28 08:20:01 UTC
(In reply to Rizal Muttaqin from comment #1)
> Please tell me what's is Formats Only here? Is it supposed to be number
> formatting  (date, currency, etc) or more like style formatting (color,
> bold, etc)?

The new dialogs allows to get insights of the quick access functions, switch off "Run immediately" and see what happens. "Formats Only" does exactly this, paste only the formats. 

We can discuss whether this is a meaningful shortcut or if we should introduce something else (pretty easy now). Adding UX for this.
Comment 3 Rizal Muttaqin 2020-11-30 03:33:24 UTC
(In reply to Heiko Tietze from comment #2)
> (In reply to Rizal Muttaqin from comment #1)
> > Please tell me what's is Formats Only here? Is it supposed to be number
> > formatting  (date, currency, etc) or more like style formatting (color,
> > bold, etc)?
> 
> The new dialogs allows to get insights of the quick access functions, switch
> off "Run immediately" and see what happens. "Formats Only" does exactly
> this, paste only the formats. 
> 
> We can discuss whether this is a meaningful shortcut or if we should
> introduce something else (pretty easy now). Adding UX for this.

Ok then "Formats Only" paste the whole formatting: number formatting as well as style formatting, right?
Comment 4 Heiko Tietze 2020-11-30 07:44:59 UTC
(In reply to Rizal Muttaqin from comment #3)
> Ok then "Formats Only" paste the whole formatting: number formatting as well
> as style formatting, right?

Don't know actually if the command distinguishes between direct formatting and cell style. Tried with yellow background and red font color. And I don't get on what information the help is based https://help.libreoffice.org/latest/en-US/text/shared/01/pastespecialmenu.html

But what it doesn't copy is the number format meaning decimals, percent, etc.
Comment 5 Eike Rathke 2020-11-30 22:06:46 UTC
Copying number formats works for me. From styles and hard attribution.
Comment 6 Rizal Muttaqin 2020-12-01 18:46:16 UTC
(In reply to Eike Rathke from comment #5)
> Copying number formats works for me. From styles and hard attribution.

So, both formats type are copied?
Comment 7 Eike Rathke 2020-12-08 11:21:09 UTC
Yes. But maybe I misunderstood, I spoke of Calc while the help link Heiko posted is about Writer.
Comment 8 Commit Notification 2021-01-06 04:34:33 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/5a937e4bad5fb7e287bb285187d0364a42fb7224

elementary: tdf#138526 Add Formats Only paste icon

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-01-06 06:59:53 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c5e42ec2ecf03d77352e3f2ff1fba7ba2478e32d

Colibre & Sukapura: tdf#138526 Add Formats Only paste icon

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-01-06 07:00:06 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f1a6d0602e22708c4ec3a2365a154d90255ca2af

Karasa Jaga: tdf#138526 Add Formats Only paste icon

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Heiko Tietze 2021-01-06 07:22:00 UTC
For some reason I never get icons in the new dialog. Only me?
Comment 12 Rizal Muttaqin 2021-01-07 00:47:40 UTC
(In reply to Heiko Tietze from comment #11)
> For some reason I never get icons in the new dialog. Only me?

I have no issue. Every icon appears perfectly
Comment 13 Commit Notification 2021-01-08 07:41:00 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b4951108cfd38ae5d0b0782fba9b382640fdb0b2

Breeze & Sifr: tdf#138526 Add Formats Only paste icon

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 stragu 2021-08-03 13:04:55 UTC
Created attachment 174046 [details]
Missing icon in LO 7.2.0 RC2

Reopening as I can see the icon in master, but not in 7.2.0.2

Version: 7.2.0.2 / LibreOffice Community
Build ID: 614be4f5c67816389257027dc5e56c801a547089
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 15 stragu 2021-08-03 13:31:49 UTC
Seems to be GTK3-specific as I can see the icon with:

SAL_USE_VCLPLUGIN=kf5 libreoffice7.2

and with:

SAL_USE_VCLPLUGIN=qt5 libreoffice7.2
Comment 16 stragu 2021-08-03 22:52:16 UTC
I reported the GTK3 issue described in the two previous comments in Bug 143714 to track it separately.