Bug 138583 - General I/O error when opening an RTF document
Summary: General I/O error when opening an RTF document
Status: RESOLVED DUPLICATE of bug 138210
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-30 20:29 UTC by Andrej Shadura
Modified: 2020-12-01 14:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
the document LibreOffice fails to open (158.11 KB, application/rtf)
2020-11-30 20:29 UTC, Andrej Shadura
Details
another document LibreOffice fails to open (105.73 KB, application/rtf)
2020-12-01 14:43 UTC, Andrej Shadura
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrej Shadura 2020-11-30 20:29:03 UTC
Description:
The Slovak job office publishes a form at this webpage: https://www.upsvr.gov.sk/vzory-ziadosti/vzory-ziadosti-pre-oblast-sluzieb-zamestnanosti.html?page_id=13141
The direct link to the form: https://www.upsvr.gov.sk/buxus/docs/SSZ/OISS/ziadost_o_zaradenie_do_evidencie_UoZ.rtf

When I attempt to open it in LibreOffice, it gives me a General I/O error and closes.

Steps to Reproduce:
1. Open the file
2. Observe the error message.
3. Click OK.

Actual Results:
LibreOffice closes.

Expected Results:
LibreOffice shows the document.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.2.2
Build ID: 00(Build:2)
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-US
Ubuntu package version: 1:7.0.2-0ubuntu1
Calc: threaded

Happens on multiple machines.
Comment 1 Andrej Shadura 2020-11-30 20:29:34 UTC
Created attachment 167698 [details]
the document LibreOffice fails to open
Comment 2 Telesto 2020-12-01 09:02:09 UTC
No issue with
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 32fdb8eb3506bc8dcf013cc713fe8e5debceb940
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 3 Uwe Auer 2020-12-01 10:10:22 UTC
Repro on

Version: 7.0.3.1, Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US,. Calc: threaded

Version: 6.4.7.2, Build ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US, Calc: threaded

Version: 5.4.7.2, Build ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 4 Xisco Faulí 2020-12-01 11:54:12 UTC
Issue fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=8c14adfa76956e76bac98330ce67f080c90af184

*** This bug has been marked as a duplicate of bug 138210 ***
Comment 5 Andrej Shadura 2020-12-01 14:41:26 UTC
Hi,

Thanks for the quick fix. I’m curious whether this is the same issue.
Comment 6 Andrej Shadura 2020-12-01 14:43:26 UTC
Created attachment 167718 [details]
another document LibreOffice fails to open

This fails with "File format error found at 277,42974 /build/…/rtftok/rtfdocumentimpl.cxx:817(row,col)."
Comment 7 Xisco Faulí 2020-12-01 14:44:14 UTC
(In reply to Andrej Shadura from comment #5)
> Hi,
> 
> Thanks for the quick fix. I’m curious whether this is the same issue.

yes, it's. it will be fixed in LibreOffice 7.0.4