Bug 138604 - Copy/pasting image in frame ends up with blank square after paste (resolved with save file reload)
Summary: Copy/pasting image in frame ends up with blank square after paste (resolved w...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.2.0 target:7.1.4
Keywords: bibisected, bisected, regression
: 141919 (view as bug list)
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2020-12-01 15:38 UTC by Telesto
Modified: 2021-05-18 07:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-01 15:38:15 UTC
Description:
Copy/pasting image in frame ends up with blank square after paste (resolved with save file reload)

Steps to Reproduce:
1. Open attachment 167724 [details]
2. Right click the image frame on page 2 & copy
3. CTRL+N
4. CTRL+V

Actual Results:
Empty area

Expected Results:
Image


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.2

Still OK in
Version: 7.0.0.0.beta1+ (x64)
Build ID: 2891e91a513520d68ea2b8c59c14335861a15253
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Buovjaga 2021-03-31 14:20:34 UTC
Bibisected with linux-64-7.1 to
https://git.libreoffice.org/core/commit/682e0488df819c191c13a03758fad0690706e508
tdf#134099 sw: fix textbox anchors on copy-paste and undo

Adding Cc: to Miklos Vajna
Comment 2 Commit Notification 2021-04-27 07:06:08 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/feeaa5d3ca0c784344549816fbaab2c8716b4105

tdf#138604 sw textbox copy: fix missing fly frames of as-char draw frame

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Xisco Faulí 2021-04-28 08:15:35 UTC
Verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 41ff704cc49b7097b717882616011962ecd7198f
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!
Comment 4 Commit Notification 2021-04-28 08:16:27 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/603c73c73c0c5e62a02627879bc5cf2f96723f32

tdf#138604 sw textbox copy: fix missing fly frames of as-char draw frame

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Telesto 2021-04-29 18:16:17 UTC
*** Bug 141919 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2021-05-11 07:28:11 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/89b1c955c182a14de6a044b4db90b085d5bcddf9

Related: tdf#138604 sw: don't advertise AS_CHAR as "to char"

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2021-05-18 07:08:19 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/592d7252402048691a1f3e65fa25c059c1b87e6d

Related: tdf#138604 sw: advertise AT_CHAR as "to char"

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.