Bug 138655 - Hide Tips Of The Day when showing Impress templates manager dialog
Summary: Hide Tips Of The Day when showing Impress templates manager dialog
Status: RESOLVED DUPLICATE of bug 143353
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Tip-Of-The-Day
  Show dependency treegraph
 
Reported: 2020-12-04 09:43 UTC by Rizal Muttaqin
Modified: 2021-09-03 11:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Disturbing ToTD over Impress Template Manager dialog (64.72 KB, image/png)
2020-12-04 09:43 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2020-12-04 09:43:11 UTC
Created attachment 167822 [details]
Disturbing ToTD over Impress Template Manager dialog

Description:
Tips of The Day dialog should not be appear when opening Impress' Template Manager dialog. It's pretty annoying to close it first and select template. Yes, we can choose to click "Show Tips on Startup". But for user which choose the opposite, ToTD dialog should not smartly shows up and overlap the Template Manager dialog.

Steps to reproduce: 

1. Make sure you enable "Show Tips on startup" againts ToTD  
2. Create a new Impress presentation file
3. We got a Template Manager under ToTD dialog

Actual Results:
ToTD dialog appears in front of Template Manager dialog

Expected Results:
- ToTD does not show up when opening Template Manager dialog, or
- ToTD show up but it's placed below Template Manager dialog


Reproducible: Always


User Profile Reset: No



Additional Info:

Version: 7.0.1.1
Build ID: <buildversion>
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: id-ID (id_ID.UTF-8); UI: id-ID
Ubuntu package version: 1:7.0.1~rc1-0ubuntu0.18.04.1
Calc: threaded

Version: 7.2.0.0.alpha0+
Build ID: a5216cf1eb647862f377bed9b9a447e8bccf338f
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: id-ID (id_ID.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2020-12-03_06:36:15
Calc: threaded
Comment 1 Heiko Tietze 2020-12-04 09:46:32 UTC
Not a fan of making unrelated things depending on each other.
Comment 2 skierpage 2021-09-03 03:21:40 UTC
This happened to me with the LO Flatpak on KDE Wayland, and I can't dismiss the Tip of the Day! KDE's (X) close button, [Next Tip], and [ OK ] are all inoperative. I had to choose a template, at which point I got a second Tip of the Day window, then I could dismiss both of them.

I filed bug 144278. I don't mind seeing two stacked dialogs.
Comment 3 Heiko Tietze 2021-09-03 09:06:48 UTC
I think we can suppress the TotD when the template manager is shown. But that means it will never show up in Impress unless the TM is hidden on start. 

Looks like Caolan submitted a patch to make interaction possible. Any idea how we could "stall" the execution?
Comment 4 Caolán McNamara 2021-09-03 09:47:17 UTC
T solution I've attempted in https://git.libreoffice.org/core/+/1f42157e2457e30a7f18fdf9d7bb5bddfb819f04%5E%21 is to not allow launch of the tip of the day during startup if the template dialog is shown. And then after the template dialog is dismissed then relaunch the tip of the day dialog if one wanted to appear while the template dialog was running.

So, unless I miss something, the fix of bug 143353 solves this

*** This bug has been marked as a duplicate of bug 143353 ***
Comment 5 Heiko Tietze 2021-09-03 09:51:03 UTC
(In reply to Caolán McNamara from comment #4)
> So, unless I miss something, the fix of bug 143353 solves this

Yes, it works as expected.