Bug 138674 - New Epson Printer not working with Big Sur OS
Summary: New Epson Printer not working with Big Sur OS
Status: RESOLVED DUPLICATE of bug 138867
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha1+
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Print
  Show dependency treegraph
 
Reported: 2020-12-05 15:04 UTC by L F Bailey
Modified: 2021-05-28 08:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description L F Bailey 2020-12-05 15:04:19 UTC
Description:
EPSON WF-2860 printer

Works correctly with older MacBook pro with High Sierra, Printer Driver Version 2.0.

But not with

MacBook Pro (Retina, 15-inch, Mid 2014)

Big Sur —  Version:  11.0.1 (20B29)

JAVA  Version 8; update 271

runtime version    Oracle Corporation 13.0.1

Message when trying to print report from database app   .obd
unsatisfied query for interface of type com.sun.star.xml.sax.XDocumentHandler!

When printing .obt landscape document,  prints portrait orientation.  When cursor hovers over printer icon, does not identify default printer

Response from EPSON:

Based on the details it appears it's an issue with the application. Also, the application driver overrides the Epson printer driver.












Steps to Reproduce:
1.print .obt document
2.try to print report from .obd
3.

Actual Results:
.obt prints portrait orientation
.obd  can't print

Expected Results:
.obt landscape printing
.obd   able to print report


Reproducible: Always


User Profile Reset: No



Additional Info:
EPSON WF-2860 prints correctly with other computer using OS High Sierra and printer diver version 2.0
Comment 1 L F Bailey 2020-12-20 12:41:09 UTC
Epson Driver 3.0
Comment 2 L F Bailey 2020-12-20 13:07:12 UTC
Down loaded 7.1 Beta 1

1. able to  access and print report in .obd;  prints landscape

2.  preview .obt  shows landscape orientation;  however, when click on PRINT, image shows portrait orientation and prints portrait orientation.
Comment 3 L F Bailey 2020-12-20 13:13:08 UTC
able to print .obs   landscape
Comment 4 Roman Kuznetsov 2020-12-26 22:58:52 UTC
Can you print correctly from other software on your mac?
Comment 5 L F Bailey 2020-12-28 17:47:05 UTC
Down loaded 7.1.0.1

No change:   .obt --  preview shows landscape image;  when clicking PRINT, image shows portrait orientation and prints in portrait orientation.  Spreadsheet and database report printing prints landscape correctly.

Able to print emails landscape and to print NOTES app landscape  (choice shows up in menu)
Comment 6 QA Administrators 2020-12-29 03:44:17 UTC Comment hidden (obsolete)
Comment 7 Timur 2021-05-28 08:34:18 UTC
Looks the same to me. If not, please explain and set Unconfirmed.

*** This bug has been marked as a duplicate of bug 138867 ***