Bug 138678 - UI: Merge Format Edit Sections with Insert Section
Summary: UI: Merge Format Edit Sections with Insert Section
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-12-05 15:53 UTC by Telesto
Modified: 2021-02-11 14:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-05 15:53:05 UTC
Description:
UI: Merge Format Edit Sections with Insert Section

Steps to Reproduce:
1. Open Writer
2. Insert -> Section (listing list of pre-existing sections + number of settings)
3. Format -> Section.. listing all sections (with ability to modify/delete)

Actual Results:
There are 2 dialogs related to sections where Edit -> Section looking like a copy of 'Insert -> Section'

Expected Results:
1) Inserting & managing sections etc can be seen as one action -> not seeing point distributing those settings over separate dialogs
2) Format Section dialog looks like clone of 'Insert section'. Landed on the wrong dialog number of times. 

If separate menu entry is being needed, insert -> section being confusing when looking for modification fine (don't think is really needed, two menu items even even worse, IMHO)

My proposal: embed the few exclusive setting of 'format -> section' into the insert section dialog. I would even suggest removing the format -> section entry, but if people want it there.. be my guest..


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 32fdb8eb3506bc8dcf013cc713fe8e5debceb940
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Regina Henschel 2020-12-06 00:23:36 UTC
And how do you will alter an existing section, if there exists only "insert section"?

> 2) Format Section dialog looks like clone of 'Insert section'. Landed on the
> wrong dialog number of times. 

Why? I think it is clear: "Insert > Section" inserts a new section and "Format > Sections" formats an existing section. Very similar to "Insert > Frame" for a new frame and "Format > Frame" for changing an existing frame.
Comment 2 Telesto 2020-12-06 11:29:02 UTC
(In reply to Regina Henschel from comment #1)
> And how do you will alter an existing section, if there exists only "insert
> section"?
> 
> > 2) Format Section dialog looks like clone of 'Insert section'. Landed on the
> > wrong dialog number of times. 
> 
> Why? I think it is clear: "Insert > Section" inserts a new section and
> "Format > Sections" formats an existing section. Very similar to "Insert >
> Frame" for a new frame and "Format > Frame" for changing an existing frame.

Insert section is clear. Most critics are directed to Format -> Section

(A) I don't see 'sections' as 'formatting' in strict sense. It's kind of extending the core meaning. Or should I say, there is less Family resemblance (https://en.wikipedia.org/wiki/Family_resemblance). But this is more semantically debate

(B) Format Section bring barely new functionality. 

(D) Lots of the settings in side Format > Sections look as a copy of Insert Section

(E) I'm more the kind of managing 'sections' model. Which includes insert + deletion. Locked/unlocked stuff are connected. So should be in the same dialog.

(F) From my perspective the exclusive settings of Format -> Section can be easily ported to Format > Sections. So button to open options. I personally find more confusing to split settings across dialog compared to have all options in a single dialog. Does make it to bloated/ crowded in my perception..

However for the record. This started using a 'wrong workflow' perspective. So playing around with sections undo/redo looking for possible crashes etc. And while insert I wanted to delete a section.. Which wan't possible. 

Of course not the right course of action, but still think my vision has something worth considering..

--
Very similar to "Insert > Frame" for a new frame and "Format > Frame" for changing an existing frame

True, same 'flaw' from my perspective. Didn't look at it.. 
1. Insert -> Frame -> Frame
2. Press OK
3. With frame selected
4. Insert -> Frame -> 'Frame' item active.. You can open it.
If insert totally different from format, this shouldn't be possible at all (if you ask me)

So yes, also in this case I would 'combine'. Even though looks like the dialog being shared already.. so it's only menu item Format -> Frame which 'still present'. As said proposed, my 2 cents for that. I'm prefer less menu entry's. But surely get that 'Insert -> Section' or 'Insert -> Frame -> Frame not per se being the most obvious places to look (if you're unaware).

---
Setting to unconfirmed to get some more feedback. And sorry for question 'design' decisions on a pretty regular basis. Only putting forward how I perceive things.. and what I find unpractical/unexpected etc. Not intending to 'bend' LibreOffice to my preferences per se.. only sharing my thoughts/arguments. 
I personally find the current implementation of sections less productive/kind of cumbersome (within my logic).. 

But same thing holds true for say 'managing footnotes settings' or frames. And maybe columns (however that one is more complicated, as you explained). And the direct access to columns pretty convenient anyhow. 

---

Anyhow setting back to UNCONFIRMED.. would love bit more input from UX. Even though UX being pretty conventional: stick to what we have. So kind of skeptical of getting much support at all.. [of course lovely framing people into groups with a  conventional/progress framework. Where progress sounds like exiting compared to conventional being boring]
Comment 3 Heiko Tietze 2020-12-07 10:26:14 UTC
(In reply to Telesto from comment #2)
> (A) I don't see 'sections' as 'formatting' ...
You format the section. We can discuss if moving the command from Format to Edit makes sense since the context menu provides Edit Section.

> (B) Format Section bring barely new functionality. 
Use case that requires this is: Insert a section, modify the content, and finally protect it. Admittedly, the Link attributes are destructive (there is another ticket).
 
> (D) Lots of the settings in side Format > Sections look as a copy of Insert
> Section
It's the same dialog. Like with any other property dialog the goal is to edit what you have inserted before.

> (E) I'm more the kind of managing 'sections' model. Which includes insert +
> deletion. Locked/unlocked stuff are connected. So should be in the same
> dialog.
Don't get this.

> (F) From my perspective the exclusive settings of Format -> Section can be
> easily ported to Format > Sections. 
Neither this.

> Very similar to "Insert > Frame" for a new frame and "Format > Frame"...
Intentionally done. There are many Insert > * / Edit > * relations.

=>NAB
Comment 4 Telesto 2020-12-07 21:53:23 UTC
(In reply to Heiko Tietze from comment #3)
Hope you don't mind, recycling this topic. As I now turning 180 degrees. . Lets say Format -> Section being the right choice..

In that case I call Insert -> Sections flawed :P

A) I associate 'Insert' with insert in list, because the present of the list.
Compare Format -> Section
B) As items in the list can be selected, I assume being able to configure settings (which I can't).. Compare Format -> Section
C) The default text is 'section 1'. Press Insert.. Insert -> Section.. Click section 1 in the list.. name will be added to name field.. Which blocks insertion (as the section is in use.. not totally clear what the idea here is?
Comment 5 Heiko Tietze 2021-02-11 14:56:55 UTC
Insert and edit field are more or less identical and I bet it's using the same UI file. Don't see an issue here => NAB.