Bug 138720 - Page counter counting is pretty erratic until the final result appears
Summary: Page counter counting is pretty erratic until the final result appears
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-12-07 19:20 UTC by Telesto
Modified: 2021-04-22 17:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test document originally created with LO 7.0 saved with LO 7.2 after updating references (6.49 MB, application/vnd.oasis.opendocument.text)
2021-02-18 21:04 UTC, Stefan_Lange_KA@T-Online.de
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-07 19:20:35 UTC
Description:
Page counter counting is pretty erratic until the final result appears

Steps to Reproduce:
1. Open attachment 163675 [details]
2. Look at the page counter

Actual Results:
Page counter counts up/down

Expected Results:
Bit more stable?


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 796c7f612603490dda9277ced0f6ab3cce3bc116
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Xisco Faulí 2020-12-11 18:19:34 UTC
Reproduced in

Version: 7.2.0.0.alpha0+
Build ID: 84af20ef3ea72190784e9e7be820684c2558ba8c
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

I believe this is due to a recalculation. Description doesn't seem accurate to me
Comment 2 Xisco Faulí 2020-12-11 18:25:31 UTC
Not reproducible with GTK3
Comment 3 Xisco Faulí 2020-12-11 18:39:33 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b9ef71476fd70bc13f50ebe80390e0730d1b7afb

author	Michael Stahl <Michael.Stahl@cib.de>	2020-11-13 20:52:28 +0100
committer	Michael Stahl <michael.stahl@cib.de>	2020-11-16 16:51:19 +0100
commit	b9ef71476fd70bc13f50ebe80390e0730d1b7afb (patch)
tree	de2c044f51addf5a7ccc32f0d3289db919d5b19e
parent	094ee3955ee81e1bc631d50cc216cbb17a777839 (diff)
tdf#134298 sw: layout: remove left-over page frame without content

Bisected with: bibisect-linux64-7.1

Adding Cc: to Michael Stahl
Comment 4 Stefan_Lange_KA@T-Online.de 2021-02-18 21:04:29 UTC
Created attachment 169880 [details]
test document originally created with LO 7.0 saved with LO 7.2 after updating references

Seems the behavior described in the bug report is nearly the same as described for LOdev 7.2.0.0 in comments 7 and 10 of bug 138518 for the case of "update all references" in the test document "Test_paragraphs_divided.odt" (attached to bug 138518) created with LO 7.0.

When this test document after updating the references is saved with LOdev 7.2.0.0 (see attached document "Test_paragraphs_divided_save_#1_LOdev_7.2_2021-02-18.odt"), closed an newly opened with LOdev 7.2.0.0 the behavior as described in bug 138720 occurs.
When the test document created with LO 7.0 is opened with LOdev 7.2.0.0 it is opened normally without changing of page numbers (and reformatting of the document).
Comment 5 Michael Stahl (allotropia) 2021-04-22 16:44:17 UTC
i have doubts about my ability to reproduce this one, on recent master.

with the document from the description it goes from 230 initially to 231.

with the document from comment #4 it goes from 113 to 111 to 112 eventually.

but even with more changes in the number, it's doubtful that this would be a bug, the layout just takes some time with larger documents.

i mean, we could just block the UI completely until the layout is finished,  but i 'm not sure if that would be an improvement.

not sure if this is NOTABUG or WORKSFORME.
Comment 6 Telesto 2021-04-22 17:58:06 UTC
Nothing obviously wrong to be seen with
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: a809b2ab2553e946431699d9d7ac3f6209cbdd6b
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL