Bug 138760 - Mail Merge does not find the source data when I go back into the document.
Summary: Mail Merge does not find the source data when I go back into the document.
Status: RESOLVED DUPLICATE of bug 124680
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
Reported: 2020-12-09 03:29 UTC by moonovermyspammy@protonmail.com
Modified: 2021-07-19 19:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

Screen capture of error message (77.84 KB, image/png)
2020-12-13 02:40 UTC, moonovermyspammy@protonmail.com

Note You need to log in before you can comment on or make changes to this bug.
Description moonovermyspammy@protonmail.com 2020-12-09 03:29:34 UTC
I have created a Mail Merge Document with a data source of an *.ods spreadsheet. When I go back into the document after saving it I am unable to scroll through my mail merge documents to see each individual and then when I go to the Data Sources I get an error that says "the connection to the data sources XXXX cannot be established". Then I tried to go back through the Mail Wizard to link to the Data Source but it will then create a new data source with the same name as above but with a 1 behind it. I now have 3 data sources for this mail merge none of which work.

I have tried a variety of solutions that I have read in your documentation but the error still returns. I would like to have my mail merge document link to a spreadsheet and then save it and have it be there when I open it again.

Steps to Reproduce:
See description

Actual Results:
See description

Expected Results:
See description

Reproducible: Always

User Profile Reset: No

Additional Info:
See description
Comment 1 moonovermyspammy@protonmail.com 2020-12-09 03:40:13 UTC
This bug is also discussed in the following thread on Ask.Libreoffice:

Comment 2 moonovermyspammy@protonmail.com 2020-12-13 02:40:11 UTC
Created attachment 168119 [details]
Screen capture of error message
Comment 3 moonovermyspammy@protonmail.com 2020-12-17 01:05:04 UTC
Additional discussion thread:
Comment 4 moonovermyspammy@protonmail.com 2021-01-07 21:23:29 UTC
Extra information about my environment:

Pop! OS / Ubuntu 20.10
Gnome 3.38 Destop
Comment 5 Dieter 2021-07-07 19:59:30 UTC
Unfortunately nobody could confirm this bug report for half a year. So I'd like to ask, if it is still valid. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
And if it is still valid, perhaps you can motivate somebody from the discussion at ask.libreoffice to confirm the bug. thank you
Comment 6 Buovjaga 2021-07-19 17:11:48 UTC
(In reply to moonovermyspammy@protonmail.com from comment #1)
> This bug is also discussed in the following thread on Ask.Libreoffice:
> https://ask.libreoffice.org/en/question/187772/mail-merge-does-not-find-the-
> source-data-when-i-go-back-into-the-document/

As the discussion points to an existing bug 124680, do you think your own report should nevertheless be kept open?
Comment 7 moonovermyspammy@protonmail.com 2021-07-19 19:18:43 UTC
I found a work around long ago so I haven't done a merge in Libre Office for quite some time. If you are desiring to close the ticket feel free to do so.
Comment 8 Buovjaga 2021-07-19 19:35:01 UTC

*** This bug has been marked as a duplicate of bug 124680 ***