Download it now!
Bug 138762 - Crash when opening chart properties after creation
Summary: Crash when opening chart properties after creation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Aron Budea
URL:
Whiteboard: target:7.2.0 target:7.0.5 target:7.1....
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks: Chart Sidebar-Properties
  Show dependency treegraph
 
Reported: 2020-12-09 05:55 UTC by Aron Budea
Modified: 2020-12-11 10:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (2.15 KB, text/plain)
2020-12-09 17:52 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2020-12-09 05:55:58 UTC
- Open Writer, make sure the sidebar is closed,
- Insert a chart using the toolbar button,
- Click away from the chart once (it remains selected, but in a different way),
- Open Properties.

=> Crash.

Note that the choice to block META bug 90486 and bug 103428 instead of bug 91063 is deliberate, as the crash is related to charts and the properties deck, but not the chart properties deck.

Observed using LO 7.2.0.0.alpha0+ (b541cd9a8038810ce449f8c49ae179d9d6eaa7e8) & latest of 6.3 bibisect repo / Ubuntu.
No crash in latest of 6.2 bibisect repo.
=> regression
Comment 1 Xisco Faulí 2020-12-09 09:09:03 UTC
I can't reproduce it in

Version: 7.2.0.0.alpha0+
Build ID: 84af20ef3ea72190784e9e7be820684c2558ba8c
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 2 Aron Budea 2020-12-09 17:51:58 UTC
Bibisected to the following commit using repo bibisect-linux-64-6.3.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b5fdb148fe87a90f3e586efcea7aa6ef865fa42a
author		Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2019-04-11 15:34:13 +0200
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2019-04-12 08:17:11 +0200

"tdf#124654 Don't reopen closed sidebar decks"

Patch on gerrit: https://gerrit.libreoffice.org/c/core/+/107500
Comment 3 Aron Budea 2020-12-09 17:52:42 UTC
Created attachment 168014 [details]
Backtrace
Comment 4 Commit Notification 2020-12-10 22:40:36 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7e5991dc695d1e590483615c2907811ce4117834

tdf#138762: crash when trying to open sidebar w chart in Writer

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Aron Budea 2020-12-10 22:49:31 UTC
Backports to 7.1 and 7.0 are on gerrit.

Opening the sidebar deck still doesn't work, it just shows a large grey area, but that isn't new behavior, it was the same back in 5.2.
Comment 6 Commit Notification 2020-12-11 09:57:18 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/d0f3639a5a91ff69e5a0c8883cabb8558803ec85

tdf#138762: crash when trying to open sidebar w chart in Writer

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2020-12-11 10:04:34 UTC
Aron Budea committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/4aa9cb784469b8c13660f36c829c0fadc11c922b

tdf#138762: crash when trying to open sidebar w chart in Writer

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.