Bug 138766 - Hovering over a cell with a comment to make the comment pop up marks the document "modified"
Summary: Hovering over a cell with a comment to make the comment pop up marks the docu...
Status: RESOLVED DUPLICATE of bug 138549
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2020-12-09 08:27 UTC by Mike Kaganski
Modified: 2020-12-09 10:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A test document with a single comment (7.49 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-12-09 08:41 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2020-12-09 08:27:38 UTC
If a cell in a Calc document has a comment (Insert->Comment), then on hover over the cell's top right "comment" mark and the comment popping up, the document gets "Change object name of Callout 'ScPostIt' to 'ScPostIt_0'" undo action. It makes a saved document modified (and it asks to save edits when closed). Trying to undo crashes.

Tested with Version: 7.0.4.1 (x64)
Build ID: e3cebc55238632eae061a3da668963d484a71147
CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL
Comment 1 Mike Kaganski 2020-12-09 08:41:48 UTC
Created attachment 167995 [details]
A test document with a single comment

OK with Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL

=> regression
Comment 2 Xisco Faulí 2020-12-09 09:00:15 UTC
Not reproducible in

Version: 7.2.0.0.alpha0+
Build ID: 84af20ef3ea72190784e9e7be820684c2558ba8c
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Mike, could you please try with a build containing the fix for bug 138549?
Comment 3 Mike Kaganski 2020-12-09 10:44:29 UTC
(In reply to Xisco Faulí from comment #2)

You are absolutely right! Thank you!

*** This bug has been marked as a duplicate of bug 138549 ***