Bug 138788 - VIEWING - When inserting an object into the Writer- Image isn't viewable
Summary: VIEWING - When inserting an object into the Writer- Image isn't viewable
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-09 22:12 UTC by cowboy1212
Modified: 2020-12-22 14:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screen shot of issue (96.64 KB, image/png)
2020-12-09 22:13 UTC, cowboy1212
Details
SecondScreen Shot of issue (124.26 KB, image/png)
2020-12-09 22:14 UTC, cowboy1212
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cowboy1212 2020-12-09 22:12:01 UTC
Description:
I am having an issue when insert objects (equations, images, charts/graphs copied from other program)into Libre Writer. The inserted item is not viewable in the normal view of the document.  Inserted Items are only labeled as a large box with 'Object X' (x being the number of objects inserted) When print preview is opened the image is available.  This does not allow inserted images to be viewable when emailing a document or submitting documents electronically.

Steps to Reproduce:
1. Open Writer.
2. Insert object or copy a chart from Calc and paste
3. inserted item should be a box with object 1 in upper left hand corner.
4. Open print preview and Object box should display actual inserted item.

Actual Results:
Open Writer
Insert object (equation or a chart fro Calc)
Box appears with "Object 1" in upper left corner. 
Repeat and Object 2 is in upper left corner. 
Open print preview and insert image is shown correctly

Expected Results:
Inserted items should be viewable on the normal view of the document for electronic editing, sending or submitting purposes. 


Reproducible: Always


User Profile Reset: Yes



Additional Info:
I have submitted a similar bug report for inserting an equation and I think this would help to correct the issue.  I have screen shots of my documents to better show the issue I am having.
Comment 1 cowboy1212 2020-12-09 22:13:33 UTC
Created attachment 168017 [details]
screen shot of issue
Comment 2 cowboy1212 2020-12-09 22:14:00 UTC
Created attachment 168018 [details]
SecondScreen Shot of issue
Comment 3 Telesto 2020-12-10 04:26:09 UTC
Menu View -> Images and charts
Comment 4 Laura Garcia 2020-12-17 10:39:58 UTC Comment hidden (obsolete)
Comment 5 Laura Garcia 2020-12-17 10:40:51 UTC
Thank you for reporting the bug. I can confirm that the bug is present in
Version: 7.2.0.0.alpha0+
Build ID: d9ccee2231a8d8984302e1b2f578bf73b4d60c35
CPU threads: 4; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

But insert and print preview works properly with.
Version: 7.0.3.1
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

Additional Comments:
When testing with Version: 7.2.0.0.alpha0+, the chart inserted from Calc doesn’t show up. There’s an object inserted, which is only obvious because of the border that it shows when selected (it’s not labeled as "object 1" like described by user). Print preview isn’t showing the object, just a blank page.
Comment 6 Buovjaga 2020-12-22 14:44:08 UTC
(In reply to Telesto from comment #3)
> Menu View -> Images and charts

Indeed, not a bug. Cowboy, please change the setting.