Bug 138821 - Bug with border of tables in .pptx
Summary: Bug with border of tables in .pptx
Status: RESOLVED DUPLICATE of bug 135552
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: PPTX-Tables
  Show dependency treegraph
 
Reported: 2020-12-11 13:50 UTC by Zoe
Modified: 2021-01-25 09:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of bug (152.66 KB, image/png)
2020-12-11 13:54 UTC, Zoe
Details
Table made in PowerPoint (24.57 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-12-11 15:38 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zoe 2020-12-11 13:50:21 UTC
Description:
After saving a .pptx file with a table that has borders set to all, when I reopen the file, the right border of the top right cell is missing.
I have only tested this with tables where the entire top row is merged (as this is how I was using the table).
I have not tested how it displays after saving in other editing software (eg MS office) as I do not have any others installed.

Steps to Reproduce:
1. create table at least 2 wide
2. merge entire top row
3. set borders to all
4. save file
5. exit libreoffice
6. open file

Actual Results:
Right border of the top right cell appears blank

Expected Results:
All borders remain intact


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Version: 7.0.3.1
Build ID: 00(Build:1)
CPU threads: 4; OS: Linux 5.9; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded
Comment 1 Zoe 2020-12-11 13:54:36 UTC
Created attachment 168058 [details]
Screenshot of bug
Comment 2 Regina Henschel 2020-12-11 15:38:24 UTC
Created attachment 168066 [details]
Table made in PowerPoint

It is at least a "file open" problem. I see the missing cell border too, if I open a file, which is saved by PowerPoint. Try with the attached file.

There might be a "file save" problem too, because, when I open a file in PowerPoint, which was saved to pptx by LibreOffice, then PowerPoint has some parts of the border missing. The place is at the bottom of the merged cell in this case.
Comment 3 NISZ LibreOffice Team 2021-01-22 13:39:05 UTC
(In reply to Regina Henschel from comment #2)
> Created attachment 168066 [details]
> Table made in PowerPoint

This was good in:

Version: 6.0.0.3
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
Locale: en-US (hu_HU); Calc: CL

But not anymore in:

Version: 6.1.0.3
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
Locale: en-US (hu_HU); Calc: CL
Comment 4 Timur 2021-01-22 15:38:01 UTC
Let's assume duplicate of another regression

*** This bug has been marked as a duplicate of bug 135552 ***