Bug 138845 - UI: The border dots in properties -> table borders arrows have purple background (not skia)
Summary: UI: The border dots in properties -> table borders arrows have purple backgro...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.2.0 target:7.1.0.2 target:7.0.5
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2020-12-12 09:39 UTC by Telesto
Modified: 2021-01-13 13:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Shows Table with Black Borders (21.09 KB, image/png)
2020-12-12 10:48 UTC, Dave Barton
Details
Screenshot expected (72.29 KB, image/jpeg)
2020-12-12 17:06 UTC, Telesto
Details
Screenshot current (63.19 KB, image/jpeg)
2020-12-12 17:07 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-12 09:39:49 UTC
Description:
UI: The border dots in properties -> table borders are purple (not skia)ple

Steps to Reproduce:
1. Open Writer
2. Insert a table
3. Right click -> Properties
4. Borders tab

Actual Results:
User-defined borders have purple dots

Expected Results:
Black


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 796c7f612603490dda9277ced0f6ab3cce3bc116
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Dave Barton 2020-12-12 10:48:23 UTC
Created attachment 168095 [details]
Shows Table with Black Borders
Comment 2 Dave Barton 2020-12-12 10:49:13 UTC
Works for me, Propose NAB

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 35e471bb4d1388cf5afcdcee214cf5111edf44e3
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-GB
Calc: threaded
Comment 3 Telesto 2020-12-12 17:06:57 UTC
Created attachment 168107 [details]
Screenshot expected
Comment 4 Telesto 2020-12-12 17:07:18 UTC
Created attachment 168108 [details]
Screenshot current
Comment 5 Telesto 2020-12-12 17:13:48 UTC
(In reply to Dave Barton from comment #1)
> Created attachment 168095 [details]
> Shows Table with Black Borders

You're screenshot illustrating my issue :P. Compare the with expected screenshot.


@UX
I could think of some different color border pointing arrows. As you're responds suggest the current to be adequate. And I got the same 'feeling'. You could play with the 'border pointers/ arrows. So tango blue? Or something else.. but that's a UX dimension. It where black arrow pointers (so prefer to go back to what it was for now). However doesn't need to be this way :-)

Adding bibisect request as this is a regression (except not totally clear if it's the arrow pointer images being broken or something at code level.

Looks like a transparency issue to me


----
Setting to NEW based on comment 1 screenshot & my screenshot of the current state.
Comment 6 Ming Hua 2020-12-12 17:48:45 UTC
I thought this was already reported as bug 138350 and fixed in master?  Dave's screenshot definitely looks a significant improvement to your "current" one, if not exactly the same as your "expected" one.

Maybe the magenta arrow head is intentional, maybe not.  Adding Rizal to CC who should know for sure.
Comment 7 Dave Barton 2020-12-12 19:59:34 UTC
Tested on 5 different Win 10 computers and cannot reproduce your condition. This is such a ridiculously unimportant trivial issue, I have no more time to waste on it. My take is still NAB.
Comment 8 Telesto 2020-12-12 21:23:34 UTC
After updating to Master of today it's better. Look indeed as attachment 168095 [details]

Not big fan of grayish arrows and purple magenta arrow. This surely harder to read with less eye sight and purple and color blindness.. Aside from the aesthetically aspect 

So disagreeing with comment 7. It's not NAB, IMHO. Not the most impressive bug, true..
Comment 9 Rizal Muttaqin 2020-12-12 22:05:40 UTC
(In reply to Ming Hua from comment #6)
> I thought this was already reported as bug 138350 and fixed in master? 
> Dave's screenshot definitely looks a significant improvement to your
> "current" one, if not exactly the same as your "expected" one.
> 
> Maybe the magenta arrow head is intentional, maybe not.  Adding Rizal to CC
> who should know for sure.

Yes, it was fixed in bug 138350. Personally, magenta color does not have real eye catching value for me but I keep it assuming it has something to do with code.
Comment 10 Heiko Tietze 2020-12-15 09:40:34 UTC
Has been fixed meanwhile by Caolan.

*** This bug has been marked as a duplicate of bug 138450 ***
Comment 11 Rizal Muttaqin 2021-01-02 23:07:16 UTC
Please see https://bugs.documentfoundation.org/show_bug.cgi?id=138350#c8

This bug is not a duplicate tdf#138350 rather another bug.

I will send the patch by God's will.
Comment 12 Commit Notification 2021-01-03 04:19:41 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a881fb16c99956d012eac7b210d8b5928faa4dde

Colibre: tdf#138845 fix for unecessary magenta/purple background

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2021-01-03 13:43:42 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/2141107b0b9a6606cee4744ca874611786c0c3ac

Colibre: tdf#138845 fix for unecessary magenta/purple background

It will be available in 7.1.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2021-01-03 16:10:57 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/299bbbc12727529c78a023676fc2ad7fff8e2b2a

Colibre: tdf#138845 fix for unecessary magenta/purple background

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Heiko Tietze 2021-01-13 09:21:40 UTC
Ìs it resolved with your patches, Rizal?
Comment 16 Telesto 2021-01-13 09:43:54 UTC
The issue is surely gone
Comment 17 Rizal Muttaqin 2021-01-13 11:02:55 UTC
(In reply to Heiko Tietze from comment #15)
> Ìs it resolved with your patches, Rizal?

yeaa, it should
Comment 18 Rizal Muttaqin 2021-01-13 13:16:05 UTC
Verified Fix

Version: 7.2.0.0.alpha0+
Build ID: 82cb5a3bb27bb70c97b3d04b9de97a3ff67231c5
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: kf5
Locale: id-ID (id_ID.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-01-12_20:54:16
Calc: threaded