Bug 138851 - Named range manager always display "Document (Global)" when launching
Summary: Named range manager always display "Document (Global)" when launching
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.0.0.beta2 tar...
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-12-12 12:41 UTC by Julien Nabet
Modified: 2020-12-14 13:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2020-12-12 12:41:53 UTC
Description:
On pc Debian x86-64 with master sources updated today or with LO Debian package 7.0.3.1, Named range manager in Calc always display "Document (Global)" when launching it even if the variable name has another scope.
If you have several variables, when you select another variable in the manager and go back to the initial variable, it's ok.


Steps to Reproduce:
1. Launch Calc
2. Create 2 named ranged variables (Sheet\Named Ranges and Expressions\Define...) with a scope different from "Document (Global)"
3. open the dialog to manage the named ranges (shortcut Ctrl-F3)


Actual Results:
Notice scope is "Document (Global)" for first variable

Expected Results:
Scope for first variable should display what you defined


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.3.1
Build ID: 00(Build:1)
CPU threads: 12; OS: Linux 5.9; UI render: default; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Debian package version: 1:7.0.3-4+b1
Calc: threaded
Comment 1 Julien Nabet 2020-12-12 12:42:41 UTC
Pablovx: would you have some time to confirm this one?
Comment 2 raal 2020-12-12 13:28:58 UTC
Confirm with Version: 7.2.0.0.alpha0+
Build ID: b541cd9a8038810ce449f8c49ae179d9d6eaa7e8
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded

regression, works in 6.1
Comment 3 raal 2020-12-12 13:59:58 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara ; Could you possibly take a look at this one?
Thanks

repo: linux-64-6.5 
1daab7c8c95aa83ce37d6b8c4db5fa94ed6caf4d is the first bad commit
commit 1daab7c8c95aa83ce37d6b8c4db5fa94ed6caf4d
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Wed Nov 20 13:46:16 2019 +0100

    source sha:19116d1061b287eef600ec6b3f46c362a4abd405

https://gerrit.libreoffice.org/c/core/+/83283
Comment 4 Julien Nabet 2020-12-12 16:19:47 UTC
I gave a try with:
https://gerrit.libreoffice.org/c/core/+/107638
but perhaps it's not the right fix because unrelated with commit quoted in https://bugs.documentfoundation.org/show_bug.cgi?id=138851#c3
Comment 5 Commit Notification 2020-12-13 20:22:30 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/10cf4d5193df2f804176c05a843e801077dbf2ce

tdf#138851: Named range manager always display "Document (Global)" at launching

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2020-12-13 20:24:42 UTC
I think Julien's fix is the right one in this case. Fixed in master with backports to 7-1 and 7-0 in gerrit
Comment 7 Commit Notification 2020-12-14 08:40:49 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/4fe34da54b5e561f17cebcccbebc76d504fee0f1

tdf#138851: Named range manager always display "Document (Global)" at launching

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2020-12-14 12:36:26 UTC
Verified in

Version: 7.2.0.0.alpha0+
Build ID: 9a2a4bc5ed340ba187c8e27db5c8477c990c93af
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Julien, thanks for fixing this issue!
Comment 9 Commit Notification 2020-12-14 12:38:13 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/bb3d6a788001436ef29d0f5e53431c8c0a75040e

tdf#138851: Named range manager always display "Document (Global)" at launching

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2020-12-14 13:03:32 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/1c38093b9214b2d417d12cc091cfc1f211a49777

tdf#138851: sc: Add UItest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.