Bug 138909 - Imported templates not shown immediately in template manager
Summary: Imported templates not shown immediately in template manager
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
(earliest affected)
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Template-Manager
  Show dependency treegraph
Reported: 2020-12-14 17:45 UTC by Heiko Tietze
Modified: 2021-01-04 12:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2020-12-14 17:45:17 UTC
Open the template manager and import a template. It's not show even when categories or filters are changed. It shows up only when the dialog is started again.
Comment 1 Heiko Tietze 2020-12-14 17:45:32 UTC
Build ID: 1b69f0c2731ec66e76073ab0f2936b7112bf1e77
CPU threads: 8; OS: Linux 5.9; UI render: default; VCL: kf5
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 2 sdc.blanco 2020-12-15 00:56:45 UTC
Not reproduced.  Imported template from directory outside of Template Manager, Template shown immediately in Template Manager.

Version: (x64)
Build ID: 368c56144aab5794c39d5bc2082d9b3d6d7cebdb
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_DK); UI: en-US
Calc: threaded

Did you try "Refresh" button in Settings (instead of restarting dialog)?
Comment 3 Heiko Tietze 2020-12-15 06:57:44 UTC
Tested with Refresh and that works but I have to change the filter (starting from All/All). But why should I have to refresh manually, a function hidden in a weird menu.
Comment 4 sdc.blanco 2020-12-15 08:11:04 UTC
(In reply to Heiko Tietze from comment #3)
> But why should I have to refresh manually, a function hidden
> in a weird menu.
Presumably a rhetorical question?

My query was motivated only for trying to localize a possible cause of a presumably undesirable behavior.  We can agree that user should not be required to use "refresh" (or restarting the template manager) in this case.

Adding "see also" to bug 132042, which also has a situation that is "solved" by using refresh.

(as for weird menu and hidden function, maybe you should add needsUXEval (-: )
Comment 5 Heiko Tietze 2020-12-15 10:44:04 UTC Comment hidden (off-topic)
Comment 6 sdc.blanco 2020-12-20 08:45:59 UTC
@Heiko -- have you tried this with different different VCLs in Linux?

I am not able to reproduce this bug under Windows.  When I import a template, it  appears immediately in the Template Manager (both in Thumbnail and Listview).

This might be a linux-specific problem -- and possibly only for certain vcls.
Comment 7 Heiko Tietze 2021-01-04 12:39:34 UTC
Cannot repro either. Perhaps my fault with setting the wrong category/filter.