Bug 138914 - Unable to delete unwanted paragraph before TOC
Summary: Unable to delete unwanted paragraph before TOC
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: TableofContents-Indexes
  Show dependency treegraph
 
Reported: 2020-12-14 20:50 UTC by Alan Robinson
Modified: 2022-09-05 14:56 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document demonstrating and describing problems (24.13 KB, application/vnd.oasis.opendocument.text)
2020-12-14 20:51 UTC, Alan Robinson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Robinson 2020-12-14 20:50:22 UTC
Description:
Simply placing the caret in the unwanted paragraph before the TOC and pressing Del did not work. the attached document describes various attempts to get round the problem, without success.

Steps to Reproduce:
1. Open attached document and follow instructions.

Actual Results:
Failure to delete unwanted paragraph

Expected Results:
Ability to delete unwanted paragraph


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: en-GB (en_GB); UI: en-GB
Calc: threaded
Comment 1 Alan Robinson 2020-12-14 20:51:55 UTC
Created attachment 168164 [details]
Document demonstrating and describing problems
Comment 2 [REDACTED] 2020-12-15 10:47:27 UTC
Move to last (empty) paragraph on the first page and use DEL key - or use BACKSPACE if being on the empty paragraph before TOC. Thus 

no repro 

Version: 6.4.7.2, Build-ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU-Threads: 8; BS: Linux 5.3; UI-Render: GL; VCL: kf5; 
Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE,Calc: threaded

Version: 7.0.4.2, Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US, Calc: threaded
Comment 3 Alan Robinson 2020-12-15 12:40:14 UTC
Hello Uwe,

No, sorry, it's not that simple. These actions remove the page break, not the paragraph. It's then necessary to put the page break back in directly before the TOC. The difficulties with this are described under headings 1.4 to 1.7.

I still do not understand why putting the caret before the TOC and pressing Del does not work. It seems to me that Del means delete before the caret. The software appears to treat a caret at the start of the TOC as being inside it, whatever the user does. The way it behaves is counterintuitive, to say the least.

Regards, Alan R.
Comment 4 Stéphane Guillou (stragu) 2022-09-05 14:56:30 UTC
I can confirm in:

Version: 7.0.6.2
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

In 6.3 and 6.4, the paragraph wouldn't delete but it wouldn't bring up the same error message.

However, it is possible to remove the paragraph before the TOC in:

Version: 7.1.8.1 / LibreOffice Community
Build ID: e1f30c802c3269a1d052614453f260e49458c82c
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

as well as:

Version: 7.5.0.0.alpha0+ / LibreOffice Community
Build ID: 24087697d5cf78aac346d4dcea0596373e15a95c
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Therefore, marking as RESOLVED - WORKS FOR ME.