Bug 138939 - Shape gets deselected opening the animation sidebar's pane
Summary: Shape gets deselected opening the animation sidebar's pane
Status: RESOLVED DUPLICATE of bug 137637
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-12-15 12:39 UTC by Xisco Faulí
Modified: 2021-08-18 09:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-12-15 12:39:04 UTC
Steps to reproduce:
1. Open Impress
2. Insert a shape
3. Click on animation in the sidebar

-> The shape gets deselected. if it crashes, it has been reported in bug 138935

Reproduced in

Version: 7.2.0.0.alpha0+
Build ID: 9a2a4bc5ed340ba187c8e27db5c8477c990c93af
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2020-12-15 12:40:33 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=21e8ce9ab9a522d25e95773af59b7ccccaee4e54

author	Caolán McNamara <caolanm@redhat.com>	2020-03-24 11:44:16 +0000
committer	Caolán McNamara <caolanm@redhat.com>	2020-04-06 21:24:40 +0200
commit	21e8ce9ab9a522d25e95773af59b7ccccaee4e54 (patch)
tree	75e0730830aade810b84ccb3f51ba511faf03513
parent	01546c005eaf6bce8fe4066dbec92c5655190a2a (diff)
weld custom animation panel

Bisected with: bibisect-linux64-7.0

Adding Cc: to Caolán McNamara
Comment 2 Xisco Faulí 2020-12-22 22:44:04 UTC
Still reproducible in

Version: 7.2.0.0.alpha0+
Build ID: 6156a419a2d3f09d91afd00f84c84ba717442f43
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Caolán, if you have a comment, could you please take a look at this issue ?
Comment 3 Xisco Faulí 2021-08-18 09:00:37 UTC
This issue got fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=fcc0e6983f2e736022ecf22726cc34e50bd53f24
Closing as duplicated of bug 137637

*** This bug has been marked as a duplicate of bug 137637 ***