Bug 138956 - Pattern fill not available (and can cause crash)
Summary: Pattern fill not available (and can cause crash)
Status: RESOLVED DUPLICATE of bug 138973
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-12-15 20:34 UTC by Telesto
Modified: 2020-12-28 07:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
crash stack trace of STR changing area fill from bitmap to pattern SB Properties deck, similar with Area fill dialog (11.98 KB, text/plain)
2020-12-18 16:03 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-15 20:34:26 UTC
Description:
Pattern fill not available

Steps to Reproduce:
1. Open Writer
2. insert a shape
3. Pick pattern fill
4. Go to sidebar -> Pick pattern fill again in the sidebar -> crash

Actual Results:
Empty (and switching number of times did cause a crash for me)

Expected Results:
Available


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 15e4427e8fb56a143caa28b8a3120f3761fc77a5
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-12-16 09:33:07 UTC Comment hidden (off-topic)
Comment 2 Aron Budea 2020-12-17 07:05:47 UTC
These steps aren't clear to me.

(In reply to Telesto from comment #0)
> Steps to Reproduce:
> 1. Open Writer
> 2. insert a shape
> 3. Pick pattern fill
Where? I assumed the dropdown in the 'Drawing object properties' toolbar.

> 4. Go to sidebar -> Pick pattern fill again in the sidebar -> crash
vs.
> Actual Results:
> Empty (and switching number of times did cause a crash for me)
Does it crash right away, or after switching a "number of times"? I can't reproduce the crash with these, nor with comment 1's steps, though I tried in Linux.

What I could reproduce is that switching to Pattern fill via the toolbar button doesn't work properly. This looks like an implementation error from the following commit, bibisected repo using bibisect-linux-64-5.3:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=76585ae33f3ca75c05c0ccbf6a621b6e2d42bc00
author		Rishabh Kumar <kris.kr296@gmail.com>	2016-06-07 16:58:20 +0530
committer	Katarina Behrens <Katarina.Behrens@cib.de>	2016-06-28 19:37:44 +0000

Convert Bitmap tab to Pattern tab
Comment 3 Telesto 2020-12-17 08:45:34 UTC
(In reply to Aron Budea from comment #2)
1. Open Writer
2. Insert a shape
3. Pick pattern fill (in (default)toolbar)
4. Go to sidebar -> Pick pattern fill again in the sidebar -> crash

FWIW: This might be related to the crash Stuart reported for the sidebar gallery button in recent versions
Comment 4 Aron Budea 2020-12-18 15:24:45 UTC
I could repro, and bibisect the crash to the same commit as bug 138973, thus marking as duplicate.

*** This bug has been marked as a duplicate of bug 138973 ***
Comment 5 V Stuart Foote 2020-12-18 16:03:20 UTC Comment hidden (obsolete)
Comment 6 V Stuart Foote 2020-12-18 16:04:47 UTC Comment hidden (obsolete)
Comment 7 Aron Budea 2020-12-28 07:48:46 UTC
(In reply to Aron Budea from comment #2)
> What I could reproduce is that switching to Pattern fill via the toolbar
> button doesn't work properly. This looks like an implementation error from
> the following commit, bibisected repo using bibisect-linux-64-5.3:
This was reported as bug 103229.