Bug 139017 - Add label "Custom Styles in Document" in "New Style from Selection" dialog box
Summary: Add label "Custom Styles in Document" in "New Style from Selection" dialog box
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: sdc.blanco
URL:
Whiteboard: target:7.2.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicDesign
Depends on:
Blocks: Styles-Dialog
  Show dependency treegraph
 
Reported: 2020-12-18 00:48 UTC by sdc.blanco
Modified: 2021-10-15 11:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sdc.blanco 2020-12-18 00:48:13 UTC
Styles>New Style from Selection  (or Styles Menu dropdown in Sidebar)

opens dialog box with title "Create Style".

Enhancement Proposal:

1. Change title of dialog box to "New Style from Selection"  (to correspond to command).

2. Change label "Style Name" to "Enter New Style Name:"

3.  Add label "Custom Styles in Document" between entry box and display window.

Reasons:
(a) the list shown in that window is the same as shown for "Custom Styles" in the Styles sidebar
(b) "in Document" communicates that the list is local to current document
(c) makes it possible to add this label as heading in help page

Also enables change to help page, linked to "Help" button in this dialog,
which is currently entitled "Create Style"
https://help.libreoffice.org/7.2/en-US/text/shared/01/05140100.html

4.  No tooltips at present, but maybe these label changes would be sufficient?
Comment 1 Heiko Tietze 2020-12-18 07:32:44 UTC
The dialog is used only for this purpose and for sake of consistency renaming makes sense. 

Code pointer: sfx2/uiconfig/ui/newstyle.ui -> property Title
Comment 2 Commit Notification 2020-12-18 11:33:25 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c19c7d0cd5cea757d854f5e7ddc6a0e1d9b709d5

Partially resolves: tdf#139017 update labels in Create Style dialog

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 sdc.blanco 2020-12-18 12:59:57 UTC
Resetting to NEW -- because the following still remains to be done (for reasons listed above).

> 3.  Add label "Custom Styles in Document" between entry box and display
> window.
Comment 4 sdc.blanco 2020-12-20 08:38:19 UTC
changed summary to reflect what remains to be done (see comment 3)
Comment 5 sdc.blanco 2020-12-21 08:13:58 UTC
The "Custom Styles" list is always "relative" to which style category is selected for making the New Style.  It would be more elegant (and more useful for user) to have the label for the category list to shift, relative to which style category is being used.

For example, from Styles > New Style from Selection, only paragraph styles can be updated, so the label would show:  Custom Paragraph Styles for Document.

If I select List Styles category in Styles sidebar, then open Styles actions menu in Sidebar and select "New Style from Selection", then only custom list styles are shown in the list box, so the label should show:  "Custom List Styles for Document"

(by indicating which category is being used in making the new style, the user gets feedback about which category is being used. This is particularly relevant for the drag-and-drop method.)
Comment 6 Caolán McNamara 2020-12-22 11:29:38 UTC
I don't know if https://gerrit.libreoffice.org/c/core/+/108159 does what is wanted here but it at least provides an example
Comment 7 Commit Notification 2021-01-13 19:53:44 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/16de504efde4d747383f2bf33c8d2b082a06e3c1

tdf#139017 add label for styles list in New Style from Selection dialog

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 sdc.blanco 2021-01-14 15:43:29 UTC
The three changes in the OP are achieved now, so closing as FIXED.
Comment 9 Stéphane Guillou (stragu) 2021-10-15 11:58:01 UTC
verified as fixed in:

Version: 7.2.2.2 / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded