Bug 139059 - The Validity list arrow doesn't appear when we have frozen columns and the next column is not visible
Summary: The Validity list arrow doesn't appear when we have frozen columns and the ne...
Status: RESOLVED DUPLICATE of bug 78472
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.2.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Cell-Validity
  Show dependency treegraph
 
Reported: 2020-12-19 11:35 UTC by Luís Mendes
Modified: 2022-07-15 09:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Simple Spreadsheet showing issue (16.31 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-01-05 05:39 UTC, Peter S Anderson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luís Mendes 2020-12-19 11:35:22 UTC
Description:
VIEWING: The Validity list arrow (that shows the list) don't apear when we have columns fixed and the next column is not visible. Thanks.

Steps to Reproduce:
1.Create a Validity list in a cell;
2.Freeze the column after the one which has cell with the Validity list;
3.Hide the column after the one which has cell with the Validity list and select the cell that should show the arrow that presents the Validity list.

Actual Results:
The arrow that presents the Validity list don't apear, so isn't possible to select any term of the Validity list.

Expected Results:
The arrow that presents the Validity list should apear, so one can select the terms of the Validity list.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Validity list "Shows a list of all valid strings or values to select from. The list can also be opened by selecting the cell and pressing Ctrl+D." Also dosen't work in the case reported.
Comment 1 Peter S Anderson 2020-12-22 22:55:55 UTC
Hi Luis,
I have attempted to reproduce your bug in 6.2.4.7 and our DEV version without any luck. Would you please us an example spreadsheet.
Thanks.... Peter.
Comment 2 Peter S Anderson 2021-01-05 05:39:39 UTC
Created attachment 168691 [details]
Simple Spreadsheet showing issue

Example calc spreadsheet sent by Luis Mendes on 28/12. Clearly shows issue. PA to make more detailed response in next comment.
Comment 3 Peter S Anderson 2021-01-05 10:00:06 UTC
I have reproduced the “problem” using the new spreadsheet (uploaded 20210105) in both 6.4.7.2 and DEV but also in Excel. The problem is not quite as described in the original report. If you have a Validity List on a cell in column A and entry focus in on the cell, an arrow selection icon appears in the adjacent cell in column B. If column A is frozen, and you use the horizontal scroll bar to display columns to the right so that column B is no longer visible , the selection icon disappears (as if it is still in column B). If you scroll back to include column B in the display, the button re-appears. Alternatively, if column B is hidden using the Hide Columns feature, the valid values arrow appears in column C and disappears if you use the horizontal scroll bar so that column C is not visible.  

This behaviour is somewhat frustrating but consistent with a fairly recent version of Excel. My view is that this is low priority bug. If a cell with a validity list is in focus then the selection arrow should display, regardless of whether the adjacent column is visible.
Comment 4 Gabor Kelemen (allotropia) 2022-07-15 09:34:08 UTC

*** This bug has been marked as a duplicate of bug 78472 ***