Bug 139065 - PDF Export: Emphasis Mark not shown in the exported PDF
Summary: PDF Export: Emphasis Mark not shown in the exported PDF
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2020-12-19 15:00 UTC by Kevin Suo
Modified: 2020-12-20 17:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test odt file (12.34 KB, application/vnd.oasis.opendocument.text)
2020-12-19 15:01 UTC, Kevin Suo
Details
screenshot (96.83 KB, image/png)
2020-12-19 15:02 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2020-12-19 15:00:06 UTC
Description:
The attached ODT file contains a simple paragraph with "Emphasis Mark" applied to the characters. When export to PDF, the emphasis mark is not shown.

Steps to Reproduce:
1. Type any text in Writer.
2. Select the text and do "Format > Character > Font Effects > Effects: Emphasis Mark: select 'dot'".
3. Export to PDF.

Actual Results:
No "Emphasis Mark" in the exported PDF.

Expected Results:
Should have "Emphasis Mark" in the exported PDF.


Reproducible: Always


User Profile Reset: No



Additional Info:
But initially reported in the Chinese LibreOffice discussion formum:
https://bbs.libreofficechina.org/thread-2647-1-1.html

debian10 linux libreoffice-writer 1:6.1.5-3+deb10u6

Also in Fedora 32, 7.1 branch updated as of today.
Comment 1 Kevin Suo 2020-12-19 15:01:10 UTC
Created attachment 168326 [details]
test odt file
Comment 2 Kevin Suo 2020-12-19 15:02:30 UTC
Created attachment 168327 [details]
screenshot
Comment 3 Ming Hua 2020-12-20 17:00:09 UTC
Reproduced on Windows with sample file in comment 1:

Version: 7.0.4.2 (x64)
Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 2; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: zh-CN (zh_CN); UI: en-US
Calc: threaded

The "Export as PDF" result has no emphasis marks.  However, using printing with "Microsoft Print to PDF" printer choice, the generated PDF has proper marks.