Bug 139101 - Help does not reflect change to TB locked by default, so handles are hidden (comment 7)
Summary: Help does not reflect change to TB locked by default, so handles are hidden (...
Status: RESOLVED DUPLICATE of bug 139122
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-12-20 16:20 UTC by Mike
Modified: 2020-12-21 14:50 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2020-12-20 16:20:19 UTC
Description:
It says in the help that in order to undock a toolbar drag the handle but there are no handles.

Steps to Reproduce:
1.Open LibreOffice
2.Try to drag a toolbar
3.Find that there are no toolbar handles

Actual Results:
The toolbar doesn't move

Expected Results:
The toolbar does move


Reproducible: Always


User Profile Reset: Yes



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 m.a.riosv 2020-12-20 16:28:29 UTC
Confirmed
Version: 7.0.5.0.0+ (x64)
Build ID: e29387a749edb1bf39ca2b558099964da42b3a4b
CPU threads: 4; OS: Windows 10.0 Build 20180; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); Interfaz: es-ES Calc: CL
Version: 7.2.0.0.alpha0+ (x64)
Build ID: e97a81e94511b52987a50b7bdb72c922899da588
CPU threads: 4; OS: Windows 10.0 Build 20180; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: es-ES Calc: CL

Last working for me:
Version: 6.4.7.2 (x64)
Build ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU threads: 4; OS: Windows 10.0 Build 20180; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US Calc: CL
Comment 2 Telesto 2020-12-20 16:29:14 UTC
Right click somewhere on the toolbar -> Uncheck Lock toolbar position
Comment 3 Mike 2020-12-20 16:37:47 UTC
Thank you Telsto. Sorry, I couldn't find that in the help.
Comment 4 Telesto 2020-12-20 18:43:34 UTC
(In reply to Mike from comment #3)
> Thank you Telsto. Sorry, I couldn't find that in the help.

No thanks needed :P. FWIW: still consider this a bug. In the sense people decided to make it locked by default: hiding the drag handle

And currently unlock being limited to a single toolbar only. So you have to unlock everything separately

And seeing you're bug report & conformation of m.a.riosv as kind of proof :P. But likely needs an army of users to convince Heiko and cum suis at UX.
Comment 5 Mike 2020-12-21 00:33:24 UTC
In the light of Telsto's comment #4, which makes eminently good sense, I've reopened this problem report. It's clearly a design flaw.
Comment 6 Telesto 2020-12-21 07:36:26 UTC
Oops, no need to convince Heiko (talking about me and generalizing) bug 92484 c16
I'm still prefer the old way.. see this bug and bug 131817 I'm aware re-starting the topic not really the way
Comment 7 Ming Hua 2020-12-21 08:41:00 UTC
IMO the help documentation should be improved to reflect the current situation that toolbars are locked by default, regardless whether and how the UX team decides to further change the toolbar behaviors.

(In reply to Mike from comment #0)
> It says in the help that in order to undock a toolbar drag the handle but
> there are no handles.
Was Mike reading this help page:
https://help.libreoffice.org/7.2/en-US/text/shared/guide/floating_toolbar.html
?
Comment 8 Mike 2020-12-21 10:26:54 UTC
(In reply to Ming Hua from comment #7)
> IMO the help documentation should be improved to reflect the current
> situation that toolbars are locked by default, regardless whether and how
> the UX team decides to further change the toolbar behaviors.
> 
> (In reply to Mike from comment #0)
> > It says in the help that in order to undock a toolbar drag the handle but
> > there are no handles.
> Was Mike reading this help page:
> https://help.libreoffice.org/7.2/en-US/text/shared/guide/floating_toolbar.
> html
> ?

Yes.

Specifically I did a search for "undocking toolbar" and got no useful suggestions so I then searched for "docking toolbar" and got to the page which you mention. On that page the nearest to talking about locking toolbars is "Toolbars are hidden by default when the Notebook bar is active." but I don't have the notebook bar active.

On that page it says:
  To Make a Toolbar a Floating Toolbar
    Click the handle at the start of the toolbar, and drag the toolbar into the document.
Comment 9 Mike 2020-12-21 10:30:26 UTC
(In reply to Telesto from comment #6)
> Oops, no need to convince Heiko (talking about me and generalizing) bug
> 92484 c16
> I'm still prefer the old way.. see this bug and bug 131817 I'm aware
> re-starting the topic not really the way

I would heartily endorse Telsto's suggestions in bug 131817 - particularly 2, 3 4nd 4.
Comment 10 V Stuart Foote 2020-12-21 14:50:54 UTC

*** This bug has been marked as a duplicate of bug 139122 ***