Bug 139118 - CRASH On opening certain files with Skia enabled
Summary: CRASH On opening certain files with Skia enabled
Status: RESOLVED DUPLICATE of bug 138973
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-12-21 09:51 UTC by NISZ LibreOffice Team
Modified: 2020-12-30 18:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-12-21 09:51:39 UTC
Recently Writer started to crash with Skia enabled on opening these files:
attachment #105633 [details] from bug #83413
attachment 155631 [details] from bug #104254
attachment 136317 [details] from bug #112456

Steps to reproduce:
    1. Open any of the attachments linked above

Actual results:
When Skia is enabled: crash on opening, but correct opening with Skia disabled.

Expected results:
No crash.

LibreOffice details:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: e57665ea6f812aff9fc87073ce947f40a8b26e9d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

Additional Information: 

Bibisected using bibisect-win64-7.2 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=c521e614359d236405754134a54e8a05bdb1c44c 
author	Noel <noelgrandin@gmail.com>	2020-12-14 13:55:49 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2020-12-14 14:34:06 +0100

loplugin:unusedenumconstants

(double checked with git checkout HEAD~1, previous commit d98cf29aa4e5ce14f0c96a18be563f5ce36879df works fine with Skia)

Adding CC to: Noel Grandin
Comment 1 Aron Budea 2020-12-21 11:50:41 UTC
This should be fixed with bug 138973, please check with a build containing the fix.
Comment 2 Telesto 2020-12-21 21:07:08 UTC
(In reply to NISZ LibreOffice Team from comment #0)
> attachment 155631 [details] from bug #104254

Way of topic here.. 
but some ever tried to save that file (above) to re-save the file to DOCX. Pretty nice example of number of flaws in import/export. It has been improved compared to 6.2 but still lacking...

More pointing it out here, because I'm surely not able to asses this kind of issue in any useful way. Nor keeping track of the already documented issues 
NISZ likely more capable of doing that, if desired..
Comment 3 Aron Budea 2020-12-25 03:35:06 UTC
Let's assume this is a dupe of bug 138973, if it still occurs in a build after 12-19, please reopen.

*** This bug has been marked as a duplicate of bug 138973 ***
Comment 4 NISZ LibreOffice Team 2020-12-30 18:24:28 UTC
(In reply to Telesto from comment #2)
> (In reply to NISZ LibreOffice Team from comment #0)
> > attachment 155631 [details] from bug #104254
> 
> Way of topic here.. 
> but some ever tried to save that file (above) to re-save the file to DOCX.
> Pretty nice example of number of flaws in import/export. It has been
> improved compared to 6.2 but still lacking...

This is the one with the image in header. It looks quite good in master apart from the image wrap problem and one empty para slipping to next page.
Is this what you mean? Doesn't sound like something terrible.

The other two are more bad, especially the first documents WordArt horror.