Bug 139120 - EDITING Changes-in-margin: $2 appears in margin after undoing paragraph deletion
Summary: EDITING Changes-in-margin: $2 appears in margin after undoing paragraph deletion
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.0.2
Keywords:
Depends on:
Blocks: tracked-changes-in-margin
  Show dependency treegraph
 
Reported: 2020-12-21 10:40 UTC by NISZ LibreOffice Team
Modified: 2021-01-04 16:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from Writer (8.26 KB, application/vnd.oasis.opendocument.text)
2020-12-21 10:40 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem in Writer (14.06 KB, image/png)
2020-12-21 10:40 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-12-21 10:40:25 UTC
Created attachment 168374 [details]
Example file from Writer

Attached example file contains some paragraphs.
When in changes-in-margin mode the paragraph before c is deleted, then undone, the margin displays “$2”.

Steps to reproduce:
    1. Open attached file
    2. Delete the paragraph before “c” so that the second paragraphs content becomes “bc”.
    3. Undo
Actual results:
Margin indicates the deletion of “$2”.

Expected results:
Nothing on the margin, since the tracked deletion is undone.

LibreOffice details:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: e57665ea6f812aff9fc87073ce947f40a8b26e9d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2020-12-21 10:40:40 UTC
Created attachment 168375 [details]
Screenshot of the problem in Writer
Comment 2 Xisco Faulí 2020-12-21 14:07:43 UTC
Reproduced in

Version: 7.2.0.0.alpha0+
Build ID: ad8485ebe11396aaac68095ef9eec819de6af26c
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 3 Commit Notification 2020-12-22 14:25:44 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/207a709bcf1af2eee7fbac8d3c30de6f8d43a8a3

tdf#139120 tdf#139127 sw: fix empty redline related crash

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2020-12-23 18:06:15 UTC
Verified in

Version: 7.2.0.0.alpha0+
Build ID: b36a40a809206a57160108b3361f42420f619c2e
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@László Németh, thanks for fixing this issue!!
Comment 5 Commit Notification 2020-12-23 18:09:29 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/8dd2e9900d4f00dbc7ce289d9ce9a9c6739b4851

tdf#139120 tdf#139127 sw: fix empty redline related crash

It will be available in 7.1.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 László Németh 2020-12-28 11:14:54 UTC
@Xisco: Many thanks for verifying and feedbacking!