Bug 139144 - FILESAVE DOCX: Missing frames in footer after export
Summary: FILESAVE DOCX: Missing frames in footer after export
Status: RESOLVED DUPLICATE of bug 140967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-12-22 07:55 UTC by Telesto
Modified: 2021-05-29 23:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (22.92 KB, application/vnd.oasis.opendocument.text)
2020-12-22 07:55 UTC, Telesto
Details
The example file and its docx-version in 7.2alpha (164.89 KB, image/png)
2021-01-20 09:40 UTC, NISZ LibreOffice Team
Details
Docx-version of the example file in Writer 7.2 alpha (138.74 KB, image/png)
2021-01-20 09:57 UTC, NISZ LibreOffice Team
Details
The example file saved as docx (18.60 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-01-20 10:43 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-22 07:55:10 UTC
Description:
FILESAVE DOCX: Missing frames in footer after export

Steps to Reproduce:
1. Open the attached ODT
2. Save as DOCX
3. File reload

Modified version of: attachment 136317 [details] from bug #112456

Actual Results:
Certain frames missing

Expected Results:
Not so


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 315c7570c4a72f4c834086082825533b1e50d1bf
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-12-22 07:55:26 UTC
Created attachment 168402 [details]
Example file
Comment 2 Telesto 2020-12-22 07:56:08 UTC
Still fine with
Version: 6.3.0.0.alpha1+ (x64)
Build ID: c98b1f1cd43b3e109bcaf6324ef2d1f449b34099
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
Locale: nl-NL (nl_NL); UI-Language: en-US
Calc: CL
Comment 3 mulla.tasanim 2020-12-23 04:09:16 UTC
Thank you for reporting the bug. I can confirm that the bug is present in

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 761a672d62df1891b9f4f367a499b220ab2b33fa
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 4 NISZ LibreOffice Team 2021-01-20 09:40:55 UTC
Created attachment 169038 [details]
The example file and its docx-version in 7.2alpha

Some frames border seems to become 0 width in bibisect-7.2:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: e828d62503d06ebde0e41dc2d6dcc87c2dc77173
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 5 NISZ LibreOffice Team 2021-01-20 09:57:54 UTC
Created attachment 169039 [details]
Docx-version of the example file in Writer 7.2 alpha

It's really visible with Skia rendering:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: e828d62503d06ebde0e41dc2d6dcc87c2dc77173
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

With native rendering on the previous image the borders look acceptably.
Comment 6 NISZ LibreOffice Team 2021-01-20 10:43:58 UTC
Created attachment 169040 [details]
The example file saved as docx
Comment 7 NISZ LibreOffice Team 2021-01-20 11:30:53 UTC
The docx examples woes seems to have started with:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=dd117712bd5692f7bf3870ba91572a0bab54ab86

author	Armin Le Grand <Armin.Le.Grand@me.com>	2020-03-05 19:24:30 +0100
committer	Armin Le Grand <Armin.Le.Grand@me.com>	2020-03-06 10:10:55 +0100

tdf#124848 partial refactor hairline logic

Adding CC to: Armin Le Grand
Comment 8 NISZ LibreOffice Team 2021-01-20 11:33:07 UTC
bug #133450 was also bibisected to this commit.
Comment 9 Luboš Luňák 2021-01-20 16:15:14 UTC
So presumably duplicate of bug #133450 (including not being Skia-specific in fact).

*** This bug has been marked as a duplicate of bug 133450 ***
Comment 10 Aron Budea 2021-05-29 23:27:53 UTC
Perhaps bug 140967 (regression from the same commit) is more closely similar to this.

*** This bug has been marked as a duplicate of bug 140967 ***