Bug 139265 - PRINT DILAOG: Document in format DL has Print format A4
Summary: PRINT DILAOG: Document in format DL has Print format A4
Status: RESOLVED DUPLICATE of bug 129180
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, possibleRegression
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2020-12-27 17:40 UTC by Jürgen Richter
Modified: 2021-01-19 17:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Richter 2020-12-27 17:40:19 UTC
Description:
I have a template for printing envelopes with format DL. When the filled template should be printed every time page layout A4 is automatically selected, although the right page layout is shown on the left side of the print dialog. I must always adjust the page layout in the print dialog.
This was always correct in the past and the new behavior has only recently become noticeable.

Steps to Reproduce:
1. Use template with pagelayout DL
2. Open template and fill it
3. Open print dialog

Actual Results:
Wrong page layout is preset in the print dialog

Expected Results:
Preset the correct page layout in the print dialog


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
Comment 1 Dieter 2021-01-11 08:09:10 UTC
I confirm it with

Version: 7.2.0.0.alpha0+ (x64)
Build ID: c0eee433e079d8e3413f4691607e075b99af92b0
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: threaded

and with

Version: 6.3.6.2 (x64)
Build-ID: 2196df99b074d8a661f4036fca8fa0cbfa33a497
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: CL

Steps to reproduce
1. Format => page style => Page => Format "DL envelope"
2. File => Print

Problem is not related to templates


I'm not sure, if this is a bug or an enhancement (same result with C5 Envelope). I assume, that A4 is default setting. It will be probably the best for most cases, but not for all (especially for envelopes).

If we don't want to change this, it might be a solution to have the option "Use page format as print format" (or something similar) within the dialog or withing Options dialog

cc: Design Team for further input and decision
Comment 2 Heiko Tietze 2021-01-15 11:19:56 UTC
Duplicate of bug 62995? And bug 78916 asks for custom page size. So the expectation is clearly to take the page setting into the print setting - otherwise changing the page size to DL, C5 or whatever would be pointless.
Comment 3 Dieter 2021-01-15 11:32:00 UTC
(In reply to Heiko Tietze from comment #2)
> Duplicate of bug 62995?

I'm not really sure about it.

> And bug 78916 asks for custom page size. So the
> expectation is clearly to take the page setting into the print setting -

Yes, this should be the default setting. An alternative could be to have an option in Tools => Option => LibreOffice Writer => Print

[] Use default paper size for printing (and dropdown list)
[] Use page format as paper size for printing

But perhaps this is a little to much.
Comment 4 Heiko Tietze 2021-01-18 13:05:38 UTC
(In reply to Dieter from comment #3)
> have an option

Option for an option... sounds wrong to me. The page setting is the default for the page size dropdown without any "always keep printer size" confusion.
Comment 5 Jürgen Richter 2021-01-18 16:05:58 UTC
The question must be, if this is a wanted change or not. If not, the bug should be fixed.
Some minutes ago, I deinstalled Version 7.0.3.1 and reinstalled version 6.4.1.2. This version does not contain the bug and works very well just like all previous versions the years before (>5 years).

So the bug must be implemented in a version later than 6.4.1.2.

I suspect that this little "feature" is placed in the printing dialog. If I had a little more time to spare, I would have a look in the sources.
Comment 6 Dieter 2021-01-18 16:12:12 UTC
(In reply to Jürgen Richter from comment #5)
> Some minutes ago, I deinstalled Version 7.0.3.1 and reinstalled version
> 6.4.1.2. This version does not contain the bug and works very well just like
> all previous versions the years before (>5 years).

6.4.1.2 was released in February 2020 and LO 6.3.6.2 (see comment 1) in May 2020. So perhaps a regression.
Comment 7 NISZ LibreOffice Team 2021-01-19 17:59:35 UTC
It's always A4 by default in the Paper size dropdown since the redesign in 6.3.

*** This bug has been marked as a duplicate of bug 129180 ***