Bug 139271 - Clear formatting alternative for character style
Summary: Clear formatting alternative for character style
Status: RESOLVED DUPLICATE of bug 88512
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-12-28 09:39 UTC by Telesto
Modified: 2021-01-14 12:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (175.04 KB, image/jpeg)
2021-01-13 19:20 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-28 09:39:01 UTC
Description:
Clear formatting alternative for character style

Steps to Reproduce:
1. Open Writer
2. Menu Styles & Strong Emphasis
3. Type something
4. CTRL+A
5. Clear Formatting in paragraph dialog -> no effect
6. Clear DF -> no effect

Actual Results:
No option to remove CS style

Expected Results:
Ideally yes, I think


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 315c7570c4a72f4c834086082825533b1e50d1bf
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 sdc.blanco 2021-01-13 11:42:41 UTC
NB 1.  Cannot "remove" a character style -- because there is always a "Default Character Style"  At best, you can "reset" to "Default Character Style"

NB 2.  Customize keyboard shortcut to Apply Default Character Style (e.g., Ctrl+Shift+1)  

(or add Menu item or Toolbar item (look in Styles Category) that sets "Default Character Style)

then (in keyboard shortcut case):

Ctrl+A
Ctrl+Shift+1

(to reset all character styles to "default character style")

https://help.libreoffice.org/7.2/en-US/text/shared/01/05010000.html
Comment 2 Telesto 2021-01-13 12:27:57 UTC
(In reply to sdc.blanco from comment #1)
> NB 1.  Cannot "remove" a character style -- because there is always a
> "Default Character Style"  At best, you can "reset" to "Default Character
> Style"

Thanks for the tips.. You're right.
Only one question remains. How does this relate to the 'Clear Formatting'. Why is there a dedicated "menu item' for that?
Comment 3 sdc.blanco 2021-01-13 15:40:20 UTC
(In reply to Telesto from comment #2)
> How does *this* relate to the 'Clear Formatting'.
> Why is there a dedicated "menu item' for that?
Does "this" = "changing one applied character style to default character style"?  

Does "menu item" = Format > Clear Direct Formatting?

If "yes" is the answer to my two questions, then I predict that you have not tried the link to the help page in comment 1.

If that page does not answer your questions, then maybe this ticket should be converted to "improve documentation" -- if you can identify what more needs to be clarified.
Comment 4 Telesto 2021-01-13 19:20:22 UTC
Created attachment 168862 [details]
Screenshot

Clear Formatting entry I'm talking about (not clear Direct Formatting)
Comment 5 sdc.blanco 2021-01-14 00:08:18 UTC
(In reply to Telesto from comment #4)
> Clear Formatting 
Thanks for screenshot and clarification.

To return to your questions.

1.  "Clear formatting" is about Paragraph Styles, therefore, has nothing to do with "this"  (i.e., resetting character styles).

2.  Do not know why there is a dedicated menu item for "Clear formatting". I think it has been there since at least 2011.

https://help.libreoffice.org/7.2/en-US/text/shared/02/02010000.html

NB. Before proposing a dropdown box for character styles, please see bug 88512 and bug 131761
Comment 6 Telesto 2021-01-14 12:46:32 UTC
(In reply to sdc.blanco from comment #5)
Thanks for the answer & pointers.. think bug 88512 fits the bill

*** This bug has been marked as a duplicate of bug 88512 ***