Bug 139301 - IMPORT XLSX Not showing styles for dashed lines
Summary: IMPORT XLSX Not showing styles for dashed lines
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.4.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.2
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-29 08:32 UTC by NISZ LibreOffice Team
Modified: 2021-04-27 12:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
File with 4 lines that not showing styles (9.70 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-12-29 08:35 UTC, NISZ LibreOffice Team
Details
Screenshot of the problem in Calc (40.84 KB, image/png)
2020-12-29 08:37 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-12-29 08:32:53 UTC
Description:
Not showing styles for the lines

Steps to Reproduce:
1.Open attachement
2.Right click one of the lines


Actual Results:
The style is showing a blue field

Expected Results:
The style is showing the corrct style for the actual line


Reproducible: Always


User Profile Reset: No



Additional Info:
Verzió: 6.4.4.2 (x64)
Build az.: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU szálak: 4; OS: Windows 10.0 Build 17134; Felületmegjelenítés: GL; VCL: win; 
Területi beállítások: hu-HU (hu_HU); Felület nyelve: hu-HU
Calc: threaded
Comment 1 NISZ LibreOffice Team 2020-12-29 08:35:37 UTC
Created attachment 168549 [details]
File with 4 lines that not showing styles
Comment 2 NISZ LibreOffice Team 2020-12-29 08:37:25 UTC
Created attachment 168550 [details]
Screenshot of the problem in Calc
Comment 3 NISZ LibreOffice Team 2020-12-29 08:49:44 UTC
Steps to Reproduce:
1.Open attachement
2.Right click one of the lines
3.Click lines from the list
Comment 4 Regina Henschel 2020-12-29 17:39:25 UTC
That is not only a problem with spreadsheets but with other document types too. And it is not only an OOXML filter problem, but the names are missing too in ODF format, see bug 127266.
Comment 5 Commit Notification 2021-02-03 19:52:30 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/183c06fc02a50fb117bb6162e4d6e56cdd34fad1

tdf#139301 fix OOXML-compatible preset dash styles

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 László Németh 2021-02-04 09:15:43 UTC
    tdf#139301 fix OOXML-compatible preset dash styles
    
    Despite the purpose of the new interoperability styles
    added in commit b2d8093b19642038631dfb8f1ab6745a380a652c
    (tdf#127499 added 9 new line styles all are (var) and in line with MSO),
    collision with commit 57c9bdab377a00649299d1a4c9ed2f9e5e03b84e
    (tdf#127166, tdf#123903 improve import/export of line styles)
    resulted still missing interoperability on the user interface:
    
    1) opening an OOXML document, preset styles weren't recognized
       on the UI, also the preview was a solid line on the Drawing
       Object Properties toolbar.
    
    2) using the new compatibility preset styles, OOXML export
       resulted custom styles instead of the intended preset styles.
    
    On the UI, now the layout of the first 10 preset dash styles
    follows the OOXML standard, see 20.1.10.49 ST_PresetLineDashVal
    (Preset Line Dash Value) in ISO/IEC 29500-1, 2016:
    
        dash pattern    name (OOXML name)
    10                  "Dot"  (sysDot)
    1000                "Long Dot" (dot)
    1110                "Dash" (sysDash)
    1111000             "Long Dash" (dash)
    11111111000         "Double Dash" (lgDash)
    111010              "Dash Dot" (sysDashDot)
    11110001000         "Long Dash Dot (dashDot)
    111111110001000     "Double Dash Dot" (lgDashDot)
    11101010            "Dash Dot Dot" (sysDashDotDot)
    1111111100010001000 "Double Dash Dot Dot" (lgDashDotDot)
    
    Note: add missing "Dash Dot" (sysDashDot) and "Dash Dot Dot" (sysDashDotDot).
    Remove "Double Dot": it really wasn't an OOXML-compatible preset
    style, and it has a good replacement among the older styles,
    the similarly loosely dotted "Fine dotted", which is still
    supported for back-compatibility.
Comment 7 Commit Notification 2021-02-09 20:01:12 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/32e4d0907fa6d1fcd82b0762c3f02f4c1ee1dd94

tdf#139301 line dash interoperability: fix asynchron UI test

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-03-01 23:06:43 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/e941720d5c3e6a555c2405d5f8d9de6c37150e27

tdf#139301 fix OOXML-compatible preset dash styles

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 NISZ LibreOffice Team 2021-03-09 10:36:17 UTC
Verified in:

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 722ec600e85cca2e94e82e69f8d13773061172b9
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-GB
Calc: threaded

Thanks for fixing!