Bug 139317 - Image properties should indicate clearly if the image is embedded or liked to file
Summary: Image properties should indicate clearly if the image is embedded or liked to...
Status: RESOLVED DUPLICATE of bug 128216
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2020-12-30 11:31 UTC by Wilfried Weigelt
Modified: 2021-11-29 10:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wilfried Weigelt 2020-12-30 11:31:17 UTC
If inserting an image and choose "link" then Writer uses an absolute path:

file:///d:/Users/username/Documents/writertext/image.png

it should he by default a relative path.(expecially if the image is in the same folder as the ODT file or in a subfolder relative to the location of the ODT file) 

if changing the path to: 

file:///image.png
it doesn't work (odt is in the same folder)

also this doesn't work:

file://../image.png
file://image.png
file://./image.png
Comment 1 m.a.riosv 2020-12-30 13:18:10 UTC
You don't need to change the path, always the absolute path it's showed.

There is an option to have relative paths in:
Menu/Tools/Options/Load+Save/General - Save URLs relative to file system.
Comment 2 Wilfried Weigelt 2021-01-01 11:44:59 UTC
In the Menu /Tools/Options/Load+Save/General realative paths are set as default.

Its however confusing. 

There is in the context of image properties no hint that the shown absolute path is in reality a relative path. 

Further showing an absolute path which is not the real (real is the relative one) one is also confusing. 

Better would be: Image properties should indicate clearly if the image is embedded or liked to file. In case it is linked the real path used in the document should be shown (if if it relative then show relative). 
In case of a relative path a button which opens the path where the image is would be nice. 

Al link from the image properties to /Tools/Options/Load+Save/General would be also useful.
Comment 3 m.a.riosv 2021-01-01 12:32:18 UTC
Sorry, works or not?, the path you it's the true path which it's done at opening the file.
Comment 4 Wilfried Weigelt 2021-01-01 13:00:38 UTC
It works. 
Test: Moving ODT from D to C drive to a different folder and keeping the relative location of images - It works

Nice to have: enhancement in comment 2. (woukd have avoided this bug entry)

It still shows in image properties the absolute path of the image (however changed to new location)

Still this doesnn't work:

file:///image.png
it doesn't work (odt is in the same folder)

also this doesn't work:

file://../image.png
file://image.png
file://./image.png
Comment 5 QA Administrators 2021-01-02 03:45:54 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2021-11-25 15:32:19 UTC
(In reply to Wilfried Weigelt from comment #2)
> Better would be: Image properties should indicate clearly if the image is
> embedded or liked to file. In case it is linked the real path used in the
> document should be shown (if if it relative then show relative). 
> In case of a relative path a button which opens the path where the image is
> would be nice. 
> 
> Al link from the image properties to /Tools/Options/Load+Save/General would
> be also useful.
Comment 7 Heiko Tietze 2021-11-29 10:29:20 UTC
Yes, the relative URL should not be shown as absolute path. The issue was reported in another ticket.

*** This bug has been marked as a duplicate of bug 128216 ***