Bug 139471 - UI: LibreOffice main icon revamp
Summary: UI: LibreOffice main icon revamp
Status: RESOLVED DUPLICATE of bug 132398
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL: https://ask.libreoffice.org/t/request...
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: UI-Theming
  Show dependency treegraph
 
Reported: 2021-01-07 14:20 UTC by Telesto
Modified: 2022-08-01 11:09 UTC (History)
14 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-01-07 14:20:18 UTC
Description:
UI: LibreOffice main icon revamp. All LibreOffice components have nice pretty nice icons. But well, except the main application icons. It's looking un-inspirational, boring.

It always get the feeling it being a place holder icon (borrowed from 'new document' in Writer) or quick draft becoming default. For some historical reason. 
It really feels that way when looking looking at in the task bar of Windows or application icon in the left (Windows)

I'm not a designer, but I would love kind of icon update. I don't know if the icon left blank because no clue.. or lacking idea how to fill it. Lacking 3D effect or whatever... 

Sometimes I tend to 'squeeze' the new splash screen logo in it. Or some excerpt of it.. 

It's clearly so 'ugly' it needed a fill: seeing  (left icon) https://www.libreoffice.org/download/download/?version=7.1.0



Steps to Reproduce:
-

Actual Results:
-

Expected Results:
An update.. 


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 4e3ce9dd6ace0b22f7b3f45cf2338b201f4dc305
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2021-01-07 14:21:54 UTC
I'm pretty sure having read something about this in the past.. but forgot where an d how.

I'm going from 'keep the current' but modernize.. To total different (but in line with the current artwork)
Comment 2 Telesto 2021-01-07 14:25:35 UTC
@Rizal
I'm not totally up to speed... This has being discussed early I think..

And I personally would love some artistic impression what you would think it could be.. but maybe a 'hairy' topic.
Comment 3 Telesto 2021-01-07 14:28:52 UTC
And if we want 'basics'.. See "file bug icon" in the bug tracker :P
Comment 4 V Stuart Foote 2021-01-07 15:38:15 UTC
Prior discussions and WontFix outcomes as in see also bug 96835, bug 81248, bug 125514

But sure, we can revisit--especially icon behavior with os/DE "dark' background themes.
Comment 5 V Stuart Foote 2021-01-07 15:39:53 UTC
(In reply to V Stuart Foote from comment #4)
> bug 125514

s/ bug 125514/ bug 122514
Comment 6 Telesto 2021-01-07 15:48:26 UTC
Last time this was rejected mostly because of branding & marketing considerations. So adding those people in the loop..
Comment 7 Heiko Tietze 2021-01-14 08:50:30 UTC
This is in fact an ongoing discussion and I'm surprise that we don't had a ticket yet. What comes close is bug 50278 requesting separate starters on macOS (but I remember another ticket about the grey donkey ear image among the colorful macOS icons being quite ugly).
We had (and still have) the discussion whether or not themed icons should modify the branded MIME type icons, see bug 126074.
Someone send a proposal recently to the mailing list https://listarchives.libreoffice.org/global/design/2020/msg00155.html but we have many at https://wiki.documentfoundation.org/Design/Mimetype_Icons/Proposals. Some really fancy ideas are also on Telegram: https://t.me/LibreOfficeDesign/37942, https://t.me/LibreOfficeDesign/44966, https://t.me/LibreOfficeDesign/43200, https://t.me/LibreOfficeDesign/40267, https://t.me/LibreOfficeDesign/40259, and https://t.me/LibreOfficeDesign/37963
Comment 8 Telesto 2021-01-14 10:05:05 UTC
(In reply to Heiko Tietze from comment #7)
https://wiki.documentfoundation.org/Design/Mimetype_Icons/Proposals

Most are applications icons, not the 'main' icon .. And not sure how much change being allowed. It's the brand icon for LibreOffice. Marketing etc. 

As certain of those proposal contain whole 'doing it differently'. But well there must be some middle ground to give the artwork gui's some direction, without binding them to much.

In principle I like idea's flowing. So everything allowed.. But well there will be a comparison made with current icon.. and the 'brand icon' topic will be topic anyhow.

And less nice to let people spend time which ultimately won't make it (because of things we could have mentioned before).

Most work in dark mode (or have an 'alternative for dark mode). It's brand icon.. so also possible to use it on LibreOffice.org/ wiki.documentfoundation.org and so on
Comment 9 V Stuart Foote 2021-01-14 15:45:53 UTC
(In reply to Heiko Tietze from comment #7)

Heiko, per OP this was just about the "Document symbol" branding icon. 

Not really the individual module icons that may respond to theme, and which could use refresh as well.


> ... (but I remember another ticket about the grey donkey ear image among
> the colorful macOS icons being quite ugly).

I think that was bug 96835
Comment 10 V Stuart Foote 2021-08-28 13:02:53 UTC
*** Bug 144140 has been marked as a duplicate of this bug. ***
Comment 11 V Stuart Foote 2021-09-12 13:33:59 UTC
See David Ruben's suggested possibilities for the main application icon:

attachment 174983 [details]

attachment 174984 [details]
Comment 12 V Stuart Foote 2021-09-12 13:39:53 UTC
Sorry forgot the narrative descriptions...
 
> attachment 174983 [details]

> Main LibreOffice icon of a off white folder does not seem easy to locate on
> my descktop of muted dark greys, nor convey the idea that the project has a
> wealth of tools within it. This uses part of past website graphics setting
> out 4 major components

> 
> attachment 174984 [details]

> this uses main website graphics of the breadth of tools withing LibreOffice,
> within a folder design that I have chaged from a somewhat washed out
> off-white/grey to the dark green used in the website
Comment 13 V Stuart Foote 2021-10-21 22:33:44 UTC
*** Bug 145257 has been marked as a duplicate of this bug. ***
Comment 14 V Stuart Foote 2021-11-14 15:50:41 UTC
Christoph's 2010 legacy 'Tango' design compliant icon [1] does not show well on Dark DE themes, nor for DE that place the app icons onto a  shaped bg field like macOS. 

Can't we have a new branding design effort that "works" better as the application icon for LibreOffice?

At the least the "dog ear page" motif needs to respond to fg/bg. And for Windows where full os/DE theme is not passed through, respond to setting of LO or LO dark theme as set in the new Options Application Colors.

Or perhaps best to envision new branding marks for the Community in increasingly diverse light/dark DE mix.

=-ref-=
[1] http://luxate.blogspot.com/2010/10/1001-document-icons.html
Comment 15 eric f 2022-01-03 13:14:15 UTC
I was going to fill a feature request for this one as well.

I install libreoffice to many people. The main icon is completely demotivating and boring. 

It's not a branding or identification for libreoffice, it looks more like a random, default, placeholder icon, from a souless corporation. It needs at least a color to get more personality (like the blue color for openoffice), and a "mascott" (like the birds for openoffice)

The best to do would be to open a contest for designers, I'm sure the LibreOffice logo would get many awesome proposals!
Comment 16 Michael Warner 2022-02-11 14:37:09 UTC
*** Bug 147348 has been marked as a duplicate of this bug. ***
Comment 17 Heiko Tietze 2022-08-01 11:09:37 UTC

*** This bug has been marked as a duplicate of bug 132398 ***