Bug 139485 - Paste (⌘-v) does not work in LibreOffice when pasting text string to Save As box
Summary: Paste (⌘-v) does not work in LibreOffice when pasting text string to Save As box
Status: RESOLVED DUPLICATE of bug 126638
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-07 20:08 UTC by Jeff Baker
Modified: 2021-01-08 12:18 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Baker 2021-01-07 20:08:12 UTC
Description:
I'm Working on a Macbook Pro 2012 (MAC OS v10.15.7, Intel Core i7) and using LibreOffice v 7.0.3.1.   

I have a new Libre text document and I want to first save the document, and use a previously copied text string (from the clipboard) as the document name. The copied- text string, no matter its length, will not paste in the "Save As" box document name field.

Try it yourself: Highlight any text string (using ⌘-C), and verify that it is on the clipboard (e.g. in Finder, go to Edit/Show Clipboard). Now go to a new Libre text document and do Save As and try to paste (using ⌘-V) the clipboard contents as the new document name in the Save As box. This does not work on a Macbook using LibreOffice v 7.0.3.1.
Screen prints attached.

Steps to Reproduce:
1. Highlight any text string (using ⌘-C), and verify that it is on the clipboard
2. Open a new Libre text document and do Save As (or Save).
3. In the popup window, the default name "Untitled 1" will appear. 
4. Now do a paste (⌘-V). No text is pasted in the document name field. 

Actual Results:
Nothing happens. 

Expected Results:
The text on the clipboard should be pasted as the document name in the Save As box.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.3.1
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Jeff Baker 2021-01-07 20:19:33 UTC
Tried to reset User Profile as recommended but cannot locate it on my MacBook. 

According to your instructions located on https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile

the User Profile should be located in this folder: 

~/Library/Application Support/LibreOffice/4/user (LibreOffice 4 to 7)

However, the LibreOffice folder does not exist in the path.

Screen print: 

(base) Jefferys-MBP:Application Support jeffs_itunes$ pwd
/Library/Application Support

(base) Jefferys-MBP:Application Support jeffs_itunes$ ls
Adobe			Avast			GarageBand		Microsoft		Script Editor		com.apple.TCC
App Store		AvastHUB		Google			Mozilla			SubmitDiagInfo		com.bombich.ccc
Apple			AvastSecureLine		Macromedia		Oracle			VMware			iLifeMediaBrowser
ApplePushService	CrashReporter		Mica			ProApps			VirtualBox		regid.1986-12.com.adobe
(base) Jefferys-MBP:Application Support jeffs_itunes$ 

No LibreOffice in the Application Support folder. 
Please revert where the LibreOffice folder is supposed to be located.
Comment 2 Jeff Baker 2021-01-08 06:37:51 UTC
Just want to inform you that this Bug i reported has previously been reported a few months ago.  See 

Bug 126638 - macOS: Can't paste in Save-As field on Catalina

The person is having the exact same problem as I am.

/Jeff Baker
Comment 3 Uwe Auer 2021-01-08 12:18:48 UTC
(In reply to Jeff Baker from comment #2)
> Just want to inform you that this Bug i reported has previously been
> reported a few months ago.  See 
> 
> Bug 126638 - macOS: Can't paste in Save-As field on Catalina
> 
> The person is having the exact same problem as I am.
> 
> /Jeff Baker

*** This bug has been marked as a duplicate of bug 126638 ***