Bug 139496 - UI - LO7.1 - Look of the automatic filter
Summary: UI - LO7.1 - Look of the automatic filter
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-08 14:23 UTC by kabilo
Modified: 2021-01-09 19:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
comparison of the look of the automatic filter (110.68 KB, image/jpeg)
2021-01-08 14:25 UTC, kabilo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kabilo 2021-01-08 14:23:21 UTC
Description:
Hi, I do not know the benefits of the new look of the automatic filter, but I would advocate for the original look.The upper part (in white) distracts from the filtered data. Thanks

Actual Results:
 

Expected Results:
 


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Comment 1 kabilo 2021-01-08 14:25:43 UTC
Created attachment 168764 [details]
comparison of the look of the automatic filter
Comment 2 V Stuart Foote 2021-01-09 05:32:31 UTC
That UI change was done for bug 116675 with https://gerrit.libreoffice.org/c/core/+/104414

With some additional discussion of how the Treelist view should function for checkboxes and their labeled entries on bug 138865

=> NAB
Comment 3 V Stuart Foote 2021-01-09 05:52:08 UTC
Oh, and since complaint was about the white background color (actually Windows not passing in usable os/DE theme to set a bg color) that UI themeing change was for bug 136555

If you want an alternative, load the Windows HC a11y dark theme "GreyEve" [1]

=-ref-=
[1] https://github.com/nitschis/GreyEveTheme
Comment 4 Aron Budea 2021-01-09 09:34:16 UTC
(In reply to V Stuart Foote from comment #2)
> That UI change was done for bug 116675 with
> https://gerrit.libreoffice.org/c/core/+/104414
Actually, they UI change was done with the following commit:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a16e6122dc62f545df90b9ea4d1f4723c46336b6
author		Caolán McNamara <caolanm@redhat.com>	2020-05-28 15:24:29 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-06-12 20:03:54 +0200

weld checklistmenu
Comment 5 kabilo 2021-01-09 19:18:08 UTC
Thanks for the info. But no checkbox is at the top of the menu. And these options could be selected by clicking on the line always. For me, it's just a change of the UI. I'll get used to it. Thanks