Bug 139500 - Crash mergedlo!EditUndo::GetComment+54 press undo inside table in impress
Summary: Crash mergedlo!EditUndo::GetComment+54 press undo inside table in impress
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.2.0 target:7.1.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2021-01-08 19:33 UTC by Telesto
Modified: 2021-05-05 08:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
BT without symbols (17.07 KB, text/plain)
2021-01-08 19:38 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-01-08 19:33:38 UTC
Description:
Crash mergedlo!EditUndo::GetComment+54 press undo inside table in impress

Steps to Reproduce:
1. Open Impress
2. Ignore the template manager
3. Insert a table 3x3
4. Place cursor in A3 and type DDD
5. Double click DDD (selected)
6. Right Click -> Edit table
7. Click borders
8. Pick a different border color
9. Press OK
10. CTRL+Z
11. CTRL+Z -> Crash

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: f2171af6ce3516598d9f8bac8294025a21a5b1a2
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: nl-NL
Calc: CL
Comment 1 Telesto 2021-01-08 19:37:45 UTC
Not in
Version: 7.1.0.0.beta1+ (x64)
Build ID: f9fab4203c1aa0b9a3f27ce2713b6d5addc7df19
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: nl-NL
Calc: CL
Comment 2 Telesto 2021-01-08 19:38:31 UTC
Very similar kind of crash area as bug 139493, but stack appears to be totally different
Comment 3 Telesto 2021-01-08 19:38:54 UTC
Created attachment 168775 [details]
BT without symbols
Comment 4 pavlog 2021-01-12 20:42:07 UTC
I can't reproduce in 

Version: 7.2.0.0.alpha0+ (x64)
Build ID: ecb916667b633f8647790e040226b093760e6cfe
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 5 Caolán McNamara 2021-04-20 20:00:16 UTC
I can confirm in local build
Comment 6 Caolán McNamara 2021-04-21 09:22:30 UTC
I wonder if this is something similar to bug 131634
Comment 7 Xisco Faulí 2021-04-21 09:53:42 UTC
(In reply to Caolán McNamara from comment #6)
> I wonder if this is something similar to bug 131634

it seems not, I can reproduce it with an older build, bisecting...
Comment 8 Xisco Faulí 2021-04-21 10:00:03 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=fdeb04f7c59cf8032fe17072ed779e70505cc6ab

author	Miklos Vajna <vmiklos@collabora.com>	2020-12-15 17:17:56 +0100
committer	Miklos Vajna <vmiklos@collabora.com>	2020-12-15 22:41:14 +0100
commit	fdeb04f7c59cf8032fe17072ed779e70505cc6ab (patch)
tree	adad4589f2021a26b989814b17b3c24830cf7d55
parent	7763692e50191e2074f56e9bf698c843eed0ad00 (diff)
tdf#129961 svx: finish UI for table shadow as direct format

Bisected with: bibisect-linux64-7.2

Adding Cc: to Miklos Vajna
Comment 9 Commit Notification 2021-05-04 07:02:56 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ece86ef173cbc070c76f180d02ac80c65e07fff9

tdf#139500 svx: fix crash on changing table properties during active text edit

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-05-05 08:28:04 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/181b5538f6bdbd1d5d2f906a1ad4bc8d0a70a043

tdf#139500 svx: fix crash on changing table properties during active text edit

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.