Bug 139639 - Image not printed with contour wrap
Summary: Image not printed with contour wrap
Status: RESOLVED DUPLICATE of bug 129085
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-15 12:13 UTC by florian
Modified: 2021-01-17 18:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example document for bug (363.37 KB, application/vnd.oasis.opendocument.text)
2021-01-15 12:14 UTC, florian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description florian 2021-01-15 12:13:52 UTC
Description:
Contour-wrapped images are shown in libreoffice but not printed. Same if trying to create a PDF. 


Steps to Reproduce:
1.Insert image
2.Edit Contour / Autocontour
3.Insert text

Actual Results:
Text is printed with the contour wrapping, but the actual image is not printed

Expected Results:
Image is printed with text contour-wrapped around it


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
In Print Preview, both image and wrapping are correctly shown. The view in the  print dialog matches the faulty print result.

Result of glxinfo | grep OpenGL:
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 960M/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 390.141
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.141
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.141
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

The following resolve attempts failed: 
- Deactivate hardware acceleration in LibreOffice
- unchecking and re-checking "print images" box on print screen
Comment 1 florian 2021-01-15 12:14:37 UTC
Created attachment 168908 [details]
Example document for bug
Comment 2 BogdanB 2021-01-16 16:05:56 UTC
Confirm with
Version: 7.0.4.2
Build ID: dcf040e67528d9187c66b2379df5ea4407429775
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

Confirm also with
Version: 7.2.0.0.alpha0+
Build ID: 5adc93a9a9426ef79054751be2904896f787a8a2
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

- In the document is visible
- with Ctrl+Shift+O is visible
- Ctrl+P, in the preview is NOT visible
- on printer/on the generated PDF is NOT visibile
Comment 3 BogdanB 2021-01-16 16:07:15 UTC
The image Properties has the "Print" option checked. I don't understand the reason is not printing.
Comment 4 Timur 2021-01-17 18:04:03 UTC
Could be a duplicate of bug 129085.
Please test wirh LO 6.0 and 6.1 and see if Print Preview is OK. 
When confirming a bug, it should always be tested with older versions.
Comment 5 BogdanB 2021-01-17 18:14:50 UTC
Yes, it is the same bug. It's a duplicate.

Tested with
Version: 6.0.7.3 and it is working
Build ID: dc89aa7a9eabfd848af146d5086077aeed2ae4a5
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk2; 
Locale: ro-RO (ro_RO.UTF-8); Calc: group

*** This bug has been marked as a duplicate of bug 129085 ***