Bug 139683 - Shortcuts: Specify PDF functions in customise dialog
Summary: Shortcuts: Specify PDF functions in customise dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: All All
: medium minor
Assignee: Ayhan Yalçınsoy
URL:
Whiteboard: target:7.2.0
Keywords: difficultyBeginner, easyHack
Depends on:
Blocks: Customize-Dialog-Keyboard
  Show dependency treegraph
 
Reported: 2021-01-16 17:18 UTC by Dieter
Modified: 2021-03-27 11:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dieter 2021-01-16 17:18:30 UTC
Steps to reproduce

1. Tools => Customise => Keyboard
2. Type "PDF" ito Functions search field

Actual result:
Two entries are named PDF (Tooltip makes specific menaing clear)

Expected result:
Same as in File => Export as: "Export as PDF" and "Export Directly as PDF".
Comment 1 Raji 2021-02-15 13:11:44 UTC
Hello Dieter,

Thank you for reporting the bug. I can confirm that the bug is present in Master.

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: e0843b1fe6e39d3e5f14c8f13476008f17c8ed2e
Comment 2 Dieter 2021-02-15 13:56:25 UTC
(In reply to Raji from comment #1)
Raji, thanks for having a look at it. If you're able to confirm it, you're allowed to change status to NEW
=> NEW because of comment 1
Comment 3 NISZ LibreOffice Team 2021-02-23 09:57:07 UTC
This is about the .uno:ExportToPDF and .uno:ExportDirectToPDF commands, their 

        <prop oor:name="Label" oor:type="xs:string">
           <value xml:lang="en-US">PDF</value>

is the same, but it shouldn't be.

Code pointer:
https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/GenericCommands.xcu?r=37157772&mo=196965&fi=5102#5102
Comment 4 Commit Notification 2021-03-09 08:20:01 UTC
Ayhan Yalçınsoy committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e3feffe94ae3b1ab6cc68fadc7dc5aa19363941b

tdf#139683: Specified PDF functions in customise dialog

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Dieter 2021-03-27 11:47:44 UTC
VERIFIED with

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: f96004096268f5e71120678e32fc8c74055819aa
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Ayhan, thanks for fixing it!