Bug 139705 - Set Page Variable/Show Page Variable is Broken
Summary: Set Page Variable/Show Page Variable is Broken
Status: RESOLVED DUPLICATE of bug 134283
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) rc
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Not Assigned
Depends on:
Blocks: Fields-Variable
  Show dependency treegraph
Reported: 2021-01-17 15:21 UTC by David Burleigh
Modified: 2021-10-04 07:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

Example of master document that illustrates the problem (945.53 KB, application/zip)
2021-01-17 15:22 UTC, David Burleigh

Note You need to log in before you can comment on or make changes to this bug.
Description David Burleigh 2021-01-17 15:21:49 UTC
I use "Set Page Variable" in the header of the first page of each chapter in my books, and "Show Page Variable" in the headers of subsequent pages, in order to display the page number within the chapter. Each "chapter" is an .odt file imported into a .odm master document. (The absolute page number within the book is displayed in the footer.) This has worked fine in all versions before version 7.x, but it does not work in 7.x -- "Show Page Variable" shows nothing.

Steps to Reproduce:
See description and attached example.

Actual Results:
Header shows: "1-" on all pages of chapter.

Expected Results:
Header should show: "1-1" on first page of chapter, and "1-2" on second page, etc.

Reproducible: Always

User Profile Reset: Yes

Additional Info:
Build: https://gerrit.libreoffice.org/gitweb?p=core.git;a=log;h=dcf040e67528d9187c66b2379df5ea4407429775
Environment: CPU threads: 8; OS: Linux 5.4
Comment 1 David Burleigh 2021-01-17 15:22:39 UTC
Created attachment 168953 [details]
Example of master document that illustrates the problem
Comment 2 Dieter 2021-02-01 07:05:28 UTC
I've tried to open attachment from comment 1, but recieved the following message: "The file 'ExampleBook.zip' is corrupt and therefore cannot be opened. LibreOffice can try to repair the file."

David, could you please check the attachment?
Comment 3 Buovjaga 2021-02-17 12:06:54 UTC
Confirmed with the document.

Arch Linux 64-bit
Version: / LibreOffice Community
Build ID: dcce840cb2383873cc77da04b0bdc4526042c212
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 14 February 2021
Comment 4 David Burleigh 2021-02-17 13:14:25 UTC
I downloaded the attachment and did not find the zip file to be corrupt.
Comment 5 Buovjaga 2021-02-17 14:29:58 UTC
Bibisected with linux-64-7.0 to

and found your older report.

*** This bug has been marked as a duplicate of bug 134283 ***
Comment 6 David Burleigh 2021-10-04 07:33:33 UTC
Does that mean it will be fixed in an upcoming release?
Comment 7 Dieter 2021-10-04 07:56:44 UTC
(In reply to David Burleigh from comment #6)
> Does that mean it will be fixed in an upcoming release?

No, you have to wait until bug 134283 is fixed.