Bug 139727 - Writer assigns "Default Paragraph Style" style to the text, instead of "Text body" style
Summary: Writer assigns "Default Paragraph Style" style to the text, instead of "Text ...
Status: RESOLVED DUPLICATE of bug 47295
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-18 04:04 UTC by NarayanAras
Modified: 2021-01-18 05:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description NarayanAras 2021-01-18 04:04:09 UTC
Description:
A few weeks ago, I had raised a bug that the Navigator stopped showing all headings (H1, H2...). During the discussion, I came to know that Writer is supposed to assign "Text body" style to the "normal" text in the document.

--------
According to the developers-
1. The "Default Paragraph Style" is designed as an abstract class. It is common across all documents.
2. It defines the common characteristics of the text that gets inherited to all the other styles.
3. All the other styles are derived from this style. 
4. The "Default paragraph style" is NOT supposed to be assigned to any text.
5. The "Text body" style is a copy of the "default paragraph style", but which the user can edit per document basis.
6. Writer is supposed to automatically assign the "text body" style to "normal" text.
------------

But Writer does not seem to follow this logic: It directly assigns the "Default paragraph style" to the "normal" text in the document. I have to manually change the style to "Text body".[BUG]

This is true of all LibreOffice version, till 7.2.0 alpha.

Desired: Writer should automatically assign the "Text body" style to the "normal" text.

Steps to Reproduce:
1. Launch Writer. Launch a new document.
2. Type some text. Check its style (in the main toolbar).

Actual Results:
The "style" drop-down menu shows "Default paragraph style" [BUG]

Expected Results:
The "style" drop-down menu should be showing the "Text body" style.

BTW the label "Default paragraph style" itself is odd!
Drop the word "style" from the label.
None of the other styles have the word "style" in their names!

For example, the "Title" style is not named "Title style".
It is a bad practice! 






Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: yes
Comment 1 V Stuart Foote 2021-01-18 05:52:51 UTC
A moldy old issue... requires a change to our 'Standard' ODF "normal" template, as localized. And currently defined Text Body style has different spacing to Default style so existing Text Body will not be made the default as is.  Template(s) need rework. Known issue.

*** This bug has been marked as a duplicate of bug 47295 ***