Bug 139787 - START CENTER: left bar text goes invisible when changing application colours to black
Summary: START CENTER: left bar text goes invisible when changing application colours ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Start-Center UI-Theming
  Show dependency treegraph
 
Reported: 2021-01-20 15:38 UTC by mulla.tasanim
Modified: 2021-08-01 13:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
icon text invisible (163.11 KB, image/png)
2021-01-20 15:45 UTC, mulla.tasanim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mulla.tasanim 2021-01-20 15:38:27 UTC
Description:
start icon text goes invisible in dark mode, I tried changing text color to white but nothing helps.

Steps to Reproduce:
1.open LO
2.tools-options-application colors-general-document background-black-apply
3.tools-options-application colors-general-application background-black-apply
4.see the start icon text it becomes invisible
5.if you will point your cursor on any icon then only it will show the text

Actual Results:
start icon text goes invisible

Expected Results:
if you will point your cursor on any icon then only it will show the text.
text should be visible in dark mode.


Reproducible: Always


User Profile Reset: No



Additional Info:
Bug is present in

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

not in:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 761a672d62df1891b9f4f367a499b220ab2b33fa
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 1 mulla.tasanim 2021-01-20 15:45:39 UTC
Created attachment 169054 [details]
icon text invisible
Comment 2 stragu 2021-08-01 13:17:10 UTC
Thank you Mulla for the report

I could not reproduce in the latest bugfix version of LibreOffice 7.0:

Version: 7.0.6.2 (x64)
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 8; OS: Windows 10.0 Build 19042; UI render: default; VCL: win
Locale: en-AU (en_AU); UI: en-US
Calc: threaded

Given that I could not reproduce, and that you said you couldn't see the issue in the upcoming 7.2 version, I am marking this as WORKSFORME as it seems to be solved.

However, if you still witness it in version 7.1, 7.2 or 7.3 when retesting, please feel free to reopen.