Bug 139837 - The area to select the inner border is to small (or the dialog)
Summary: The area to select the inner border is to small (or the dialog)
Status: RESOLVED DUPLICATE of bug 143249
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-22 16:20 UTC by Telesto
Modified: 2021-07-09 18:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screencast (697.46 KB, video/mp4)
2021-01-27 13:18 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-01-22 16:20:48 UTC
Description:
The area to select the inner border is to small (or the dialog)

Steps to Reproduce:
1. Insert a 2x2 table
2. Table -> Properties -> Border tab
3. Select the inner line.. with pointer at the height of the gray square

Also seen in GEN.. GTK3 simple bigger border picker.. so less hit or miss

Actual Results:
Outer border & inner border selected

Expected Results:
Only inner


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
7.2

and in
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 1 Heiko Tietze 2021-01-26 10:04:38 UTC
Cannot follow #3; clicking the inner lines is very easy and I probably miss the point. Can you make a screencast?
Comment 2 Telesto 2021-01-27 13:18:10 UTC
Created attachment 169187 [details]
Screencast

Please include people with less motor skills or visual impaired..
Comment 3 Heiko Tietze 2021-01-27 13:38:56 UTC
All space within the dashed lines in other words between the grey rectangles are clickable. It's the full width of the pointer cursor. Don't see benefit in making it a one or two pixels larger. Any one else?
Comment 4 Telesto 2021-01-27 14:43:34 UTC
(In reply to Heiko Tietze from comment #3)
> All space within the dashed lines in other words between the grey rectangles
> are clickable. It's the full width of the pointer cursor. Don't see benefit
> in making it a one or two pixels larger. Any one else?

Still not sure if we are on the same page.. Taking the inner border as example

You select rather often 2 borders at the same time.. So horizontal & vertical. There is only small region where this doesn't happen. The region is the same in GTK3, except the whole border picker tool being larger.. so making it less problematic. 

I personally dislike the feature clicking in the area where lines cross each other selecting both lines.. At least with this ease..

I rather prefer clicking twice, instead of 'selecting 2 borders' where I wanted to select only 1
Comment 5 Heiko Tietze 2021-01-28 14:09:20 UTC
(In reply to Telesto from comment #4)
> I rather prefer clicking twice, instead of 'selecting 2 borders' where I
> wanted to select only 1

Well, just do it that way :-). 

The center area is likely the rectangle of both the vertical and the horizontal line's hot zone. Besides, seems to me kinda corner case to enable both inner borders.
Comment 6 Telesto 2021-01-28 16:45:13 UTC
(In reply to Heiko Tietze from comment #5)
> (In reply to Telesto from comment #4)
> > I rather prefer clicking twice, instead of 'selecting 2 borders' where I
> > wanted to select only 1
> 
> Well, just do it that way :-). 

It's about the clickable area.. would love the click twice, but LibreOffice doesn't let me :P

I'm talking about wanting to disable a single border. Where I constantly click at the wrong place making the selection larger

> The center area is likely the rectangle of both the vertical and the
> horizontal line's hot zone. Besides, seems to me kinda corner case to enable
> both inner borders.

Depends how you want to interpreter corner. Yes, it's in the corner of tables. And in the corner of wanting to adjust borders selectively (template doesn't fit).. 

We have to different approaches.. You're arguing from perspective with all borders disabled. I'm arguing from perspective with all borders enabled, and wanting to disable a specific one.. in principle not that relevant. Except it might explain the 'corner' difference?

If would be 'simple' I opt for the template..
Comment 7 Heiko Tietze 2021-02-01 15:03:31 UTC
(In reply to Telesto from comment #6)
> It's about the clickable area.. would love the click twice, but LibreOffice
> doesn't let me :P

You don't need to click in the center, all the way between top and bottom or left and right is available.
Comment 8 Telesto 2021-02-01 15:35:21 UTC
(In reply to Heiko Tietze from comment #7)
> (In reply to Telesto from comment #6)
> > It's about the clickable area.. would love the click twice, but LibreOffice
> > doesn't let me :P
> 
> You don't need to click in the center, all the way between top and bottom or
> left and right is available.

You did look at the screencast..
Comment 9 Telesto 2021-07-09 18:23:52 UTC

*** This bug has been marked as a duplicate of bug 143249 ***