Bug 139845 - Default styles organization leads to a confuse basic text style
Summary: Default styles organization leads to a confuse basic text style
Status: RESOLVED DUPLICATE of bug 47295
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles-Paragraph
  Show dependency treegraph
 
Reported: 2021-01-22 21:24 UTC by Gustavo
Modified: 2021-02-08 16:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo 2021-01-22 21:24:18 UTC
Description:
Libre Office Writer came with a default collection of styles. The first one is "Default Paragraph Style" that is also the style set when a "clear formatting" option is selected. However, the Heading styles (Heading, Heading 1, Heading 2...) have the next style set to "Text Body" in the "Organizer" section. So as the common user write the text, there will be both "Default Paragraph Style" (the starter and default) and "Text Body" (after titles when hit enter) to the same kind of text.
In addition, my suggestion is to follow some international standard as Vancouver to define the basic collection of styles, this will help users with low skills with text processors.

Steps to Reproduce:
1.Type some text, hit enter to new paragraph
2.Type a title text, choose a heading stile as "Heading" and hit enter to new paragraph
3.At this point, the text is written with "Text Body" style instead "Default Paragraph Style"
4.Write some text with paragraphs, styling and so. If you choose "Clear formatting", there will be a paragraph with "Default Paragraph Style" between others with "Text Body", creating difficulties when trying to apply some new definitions to the whole text.

Actual Results:
A text with two paragraph styles set to the same type of text, the body of the document.

Expected Results:
A document must have only one style to the default basic text. This is true to all formatting standards I know.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.1.0.2 / LibreOffice Community
Build ID: 53d68d29d90fd16448721a60aad68c28ff0809f5
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: threaded
Comment 1 Dieter 2021-02-06 09:38:23 UTC
So your idea is: "Next style for heading styles should be 'Default Paragraph Style' instead of 'Text Body' by default."

I agree with that proposal. I haven't checked all, but I couldn't find other style with "Text body" as next style.

But proposal is in conflict with bug 47295.

cc: Design-Team for further input and decision
Comment 2 Heiko Tietze 2021-02-08 09:30:49 UTC
I think the request is exactly as in bug 47295 to make Text Body the default. => DU 

(Gustavo, please reopen if this is wrong)

*** This bug has been marked as a duplicate of bug 47295 ***
Comment 3 Gustavo 2021-02-08 16:03:09 UTC
Thought my thread is more detailed, but yes, is the sabe basic problem.