Bug 139881 - EDITING: Fields of a report couldn't be positioned by key - changes are ignored
Summary: EDITING: Fields of a report couldn't be positioned by key - changes are ignored
Status: RESOLVED DUPLICATE of bug 139486
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-01-24 11:03 UTC by Robert Großkopf
Modified: 2021-02-24 04:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2021-01-24 11:03:12 UTC
This bug seems to be the same bug as described for many fields in a form. Could be it will be solved with https://bugs.documentfoundation.org/show_bug.cgi?id=139486 .

Download the following attachment: https://bugs.documentfoundation.org/attachment.cgi?id=168681
Open the report for editing.
Mark a field in the report.
Try to change position of a field you wish.
Set y-position to '2'.

The position will be shown in the properties, but the field won't change the position. Click anywhere and then back to the first chosen field. y-position will be set back to the old value.

You cant change the position of any field in the report by key.

This is a bug, which will make the report-editor in many parts unusable. I can't switch to an old editor of LO 6.4 (where it works) because office.version has been changed from 1.2 to 1.3 and the report will be lost.

Tested with LO 7.0.4.2 and also LO 7.1.0.2 and Daily Build 7.2 (2021-01-22) with OpenSUSE 15.2 64bit rpm Linux.
Comment 1 Xisco Faulí 2021-02-23 08:52:25 UTC
I can't reproduce it in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 26d23c96d449c201e50df04023d9cbfd59d3d133
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Could you please try again with a recent master build ?
Comment 2 Robert Großkopf 2021-02-23 09:17:33 UTC
Have tested it again. Seems it has to be solved with bug 139486.

I have set this one to Resolved and Worksforme
Comment 3 Xisco Faulí 2021-02-23 09:37:24 UTC

*** This bug has been marked as a duplicate of bug 139486 ***